1

Wordpress install. Deleted out the CiviCRM folder like many times before. Reinstalled the new one. Get the following error: Error Details

An error of type E_COMPILE_ERROR was caused in line 834 of the file /home/xxxxx/public_html/wp-content/plugins/civicrm/civicrm.php. Error message: require_once(): Failed opening required 'CRM/Core/ClassLoader.php' (include_path='.:/opt/alt/php72/usr/share/pear')

1

It's complaining about not being able to open CRM/Core/ClassLoader.php Does that file exist? Are the permissions correct to allow the webserver to read that file?

1

Another possibility is that you forgot to copy your civicrm.settings.php file into the new plugins/civicrm folder. See the docs at https://docs.civicrm.org/sysadmin/en/latest/upgrade/wordpress/

  • I don't think that path is right. That's the old one pre CiviCRM 4.7. civicrm.settings.php should be in uploads/civicrm so should not need to be copied or put back during the upgrade process. – Mick Kahn Sep 26 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.