2

I'm attempting to configure Cividesk sync for Google Apps. Running on latest installs of WP and CIVICRM.

The Cividesk screen shows that it is configured correctly.

enter image description here

But the log shows the following error: Finished execution of Cividesk sync for Google Apps with result: Failure, Error message: Google API error - either the extension is not fully configured or there is a database mismatch.

Error appearing in my log

Any suggestions on how to proceed? There is an old forum link but it simply states to re-install. Figure there might be something more current available from the stack-exchange.

Thanks.

3

The extension is configured correctly per your screenshot, so it must be an issue with the sync queue.

You can reset this queue by accessing your database (command line mysql or phpMyAdmin) and issuing the command: TRUNCATE cividesk_sync_googleapps;

The queue will be repopulated when the next sync happens.

| improve this answer | |
  • Appreciate the response, I've gone ahead and used PHPMyAdmin to issue this command. The log shows "Finished execution of Cividesk sync for Google Apps with result: Success (Nothing needed to be synchronized.)" I'll check in 24 hours when google's cache updates. Thanks again. – V3rmie Jun 17 '15 at 19:47
  • I just checked and the error continues to occur. I recently upgraded to the google app free non-profit account that provides 1000 users. Is this the version that is NOT compatible? I did read that the free version was not compatible but I was hoping it referred to the free trial (30 day) version. – V3rmie Jun 17 '15 at 21:46
  • The extension is compatible with the Google Apps for Nonprofits. Have you checked the Directory in your Contacts application? Are there any contacts there? – Nicolas at cividesk Jun 19 '15 at 0:16
  • The Directory in my Contacts application shows 0 contacts. The log shows this Full message: Finished execution of Cividesk sync for Google Apps with result: Failure, Error message: Google API error - either the extension is not fully configured or there is a database mismatch._ and once I run the TRUNCATE cividesk_sync_googleapps; in MyPHPAdmin the log shows Parameters parsed (and passed to API method): a:1:{s:7:"version";i:3;} Full message: Finished execution of Cividesk sync for Google Apps with result: Success (Nothing needed to be synchronized.) Any thoughts? – V3rmie Jun 19 '15 at 18:51
0

Are there several versions of the extension? This version here: https://civicrm.org/extensions/google-apps-sync seems obsolete. Is it working with the OAuth2 of Google?

Could you guide us, Nicolas?

Regards.

There are obsolete help windows This option will send your registration information to Cividesk. Registering is important since it allows us to judge the level of interest for the developments we are producing, and hence plan for improvements or new developments accordingly.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.