We have been stuck at CiviCRM 5.12.4 for months now. I have had issues with my Contribution page (details not needed here) as I tried to upgrade through Civi 5.14.2. So, I held off until today to try one more time on the latest stable release (also to avoid the critical warning that 5.12.4 is OBE that scares our staff).

We are running WordPress 5.2.3 and use iATS Payments 1.6.2.

This is the behavior. If I am logged into Wordpress, when I click on a contribution page, both the contact info and the billing name and address are correctly filled in. However, hardly any of our visitors create and use a WordPress login. If I am not logged in, the page does NOT have the "My billing address is the same as above" checked by default as it did before. Worse yet, if I check to use the same address for billing as for contact, it does not propagate. Someone would have to fill in every field all over again. I think this "almost" works, but am wondering what could possibly be wrong. It seems like an issue with the handler for contribution pages, as the behavior seems to change every time I try a new version.

I obviously am not going live on our main website with this behavior. If anyone would like to observe for themselves, please visit https://test.sdcbcdream.org/join/ . To see it work correctly (5.12.4), you may visit https://sdbikecoalition.org/join/.

Thanks for any help. This one has me stumped as we have always had no issues moving forward with stable versions.

  • I hate to add, but even if all the info is filled out properly, it no longer goes to the page to confirm and then click "Make Contribution." The form is completely blanked out. That same behavior ALSO occurred attempting to upgrade through 5.13 and 5.14 versions. Is this possibly an issue with the iATS payment processor extension? Commented Sep 28, 2019 at 22:01
  • One other issue is that we also have the option to simply send in a check. On our live site running Civi 5.12.4, when you check that all the credit card and billing fields dissappear and when you click Confirm Contribution, you are presented with the info where to send the check. With Civi 5.17.5, if you click on Send Payment by Check, all the credit card and billing fields remain. ??? Commented Sep 28, 2019 at 22:06
  • I've seen issues like this when there are javascript conflicts with the theme. Have you looked in the browser console to see if any error messages are showing up?
    – guyiac
    Commented Sep 30, 2019 at 16:39
  • @guyiac, that is a good suggestion as I was wondering the same, as we upgraded to a new paid and supported them about a year ago. However, I switched to one of the standard Wordpress themes, "2019" in particular, with identical behavior. I find it hard to believe it is the them specifically. I suppose, CiviCRM 5.13.x and above has a weird conflict with the later Wordpress versions (I first encountered difficult with WP 5.1 I believe). Where do I look in the browser console for javascript errors? I've never done that. I run Chrome. THANKS for the suggestions. Commented Sep 30, 2019 at 19:37
  • OK - ctrl-shift-J brings up the javascript console. Indeed there are errors. Among them, GET test.sdcbcdream.org/wp-content/uploads/elementor/css/… net::ERR_ABORTED 404 (Not Found) (index):68 GET test.sdcbcdream.org/wp-content/uploads/elementor/css/… net::ERR_ABORTED 404 (Not Found). One of our admins installed a Wordpress extension, Elementor, for block editing (easier for non-tech staff). It looks like that may be what is getting in the way somehow. I'll dig into that. Anyone else have any suggestions? Commented Sep 30, 2019 at 22:55

2 Answers 2


Just seeing activity here, I realized I moved this query to chat.civicrm.org, Wordpress channel and haystack provided a general fix to civicrm core which has been in place since late fall 2019. I forgot to close things out back here on StackExchange. The ultimate problem was not that one plugin, iframe, but our theme, Benevolent Pro, was evidently calling register_hooks_front_end() before it actually should be. It was decided that could happen with other themes as well, so haystack suggested a fix to handle that case. I haven't had any problems since then. We are running Civi 5.21.3 (ESR) and Wordpress 5.4.2 currently. You can see the whole thread at:


  • good on you for updating. i will remove my answer :-)
    – petednz - fuzion
    Commented Jun 30, 2020 at 21:45
  • I also meant to mention that Haystack's "fix" was not just for me, but it has been in CiviCRM core since 5.18 or 5.19. Protects against sloppy 3rd party theme development. Commented Jul 1, 2020 at 1:19

The newer Civicrm Version had posed many issues for me. Also it does not work properly with PHP 7.3. Eventually I have resorted to stick with civi 5.8 which i have used in 2 other sites and working properly.

  • 1
    One other thing. Turning off all plugins and using the stock "2019" Wordpress theme, all is good. However, just changing the theme to Benevelant PRO breaks it. From my previous comment, keeping all plugins active and changing theme to stock 2019, still was broken, so there evidently is a plugin conflict as well. I will try to figure it out. The CiviCRM developers need to know they really should do something. Our paid theme and plugins are used worldwide, so it seems like this is a CiviCRM core issue. Commented Oct 2, 2019 at 18:32
  • 1
    And I narrowed the plugin conflict to just one plugin, "iframe" (wordpress.org/plugins/iframe) Commented Oct 3, 2019 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.