0

There have been multiple instances of this situation in multiple installations of CiviCRM. Details for the incident that has prompted this post:

  • CiviCRM 5.16.2 on Wordpress 5.2.3
  • Using Firefox 69 and Edge (can't find version)

Attempting to record a refund to a contribution and when pressing "Record Refund", the CiviCRM spinner runs forever and the refund is never saved. Attempts to complete the transaction in Edge and Chrome also fail in the same way. Would appreciate some guidance on where to look for problems.

enter image description here

  • 1
    Spinning sometimes means something had a fatal error on the server. Check the log file on the server: civicrm.stackexchange.com/questions/15931/… – Demerit Sep 30 '19 at 17:36
  • when you click to "Record Refund" do you have the option to right-click and then open as new tab/window - if so you may see some errors generated – petednz - fuzion Oct 1 '19 at 20:14
0

Check the logs as first port of call.

Do you have customised files / templates? If so, this would be a good place to start.

Test it without your customisations.

| improve this answer | |
1

Thanks for the reminder about the logs. The CiviCRM logs had nothing in this case, but the apache error log showed (after a little digging and web searching) that I was missing the bcmath module for php. I expect that my similar problems will reveal other php errors and will start tracking them down. Thanks again

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.