3

I'm trying to install Civi 4.6 with Drupal 7, using the instructions in the wiki page referenced in the title. In step 2, it says:

As administrator in Drupal, go to Modules, click on Install New Module, and it will ask you to fill in the URL of the module. It will then fetch it and install it for you. You will need to enable the Update Manager module in the drupal modules page to see the Install New Module link.

The current link is http://sourceforge.net/projects/civicrm/files/civicrm-testing/4.6.alphax/. You will need to replace 4.6.alphax with the current minor version number.

Hit the Install Button.

Apparently the current minor version is alpha1, so I enter http://sourceforge.net/projects/civicrm/files/civicrm-testing/4.6.alpha1/, and hit Install. I get:

Cannot extract temporary://update-cache-b2aa7d22/4.6.alpha1, not a valid archive.

Maybe I should add that I'm trying to install this on my account at the web host webfaction.com. Not sure if this makes any difference.

Advice?

  • I'm having a similar problem. When I get Drupal7 up and running, I can log in as administrator at http://<site ip>/drupal7. I continue at: wiki.civicrm.org/confluence/display/CRMDOC/… and attempt to download the latest stable (4.6.5) from sourceforge.net, and I get error messages. One issue that may be mentioned out of sequence on the wiki page refers to an FTP server on the host machine? I've tried tracing the URL from sourceforge.net, but I'm just not holding my nose right. I've tried a half a dozen times with different URL's; they al – Charles Chambers Sep 17 '15 at 0:39
  • Check the rest of this thread and see how the problem I posted was solved (at least for me!). – Ken Sep 18 '15 at 2:34
  • Also note for others, SourceForge is NOT currently linking to the latest version via the DOWNLOAD button and I recommend you avoid using that button. – petednz - fuzion Sep 18 '15 at 2:51
4

You can always find the latest version on the CiviCRM website, or on Sourceforge. If using the Sourceforge link, there is a direct link to the latest version (Drupal) (others who may be interested in other CMS's can select the version for an alternate CMS):

Sourceforge CiviCRM

  • (per @petednz) It is a good idea to double check that you are getting the latest version if you use the big green "Download" button as occasionally that button lags behind the latest version slightly.
  • 2
    I just went in and fixed the page at wiki.civicrm.org/confluence/display/CRMDOC/… . It had some ridiculous instructions. – Andrew Hunt Jun 17 '15 at 21:49
  • Thank you Andrew! I'm up and running. FYI, I did step 2 with the instruction that says "upload and extract the file in <DRUPAL ROOT>/sites/all/modules". I think the "click on Install New Module, and it will ask you to fill in the URL of the module" instruction still won't work, because it doesn't specify what "the URL of the module" is. ~ Thanks again, Ken – Ken Jun 19 '15 at 0:33
  • Laryn - your link to SourceForge is taking people to a page where if they just hit the big green DOWNLOAD button they end up with 4.6.5 rather than the latest. Not your fault I know ;-) I understand this is an issue that is being looked at 'upstream' so perhaps you can edit your answer to avoid more users inadvertently getting an old version of code. – petednz - fuzion Sep 18 '15 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.