2

I am upgrading 4.2.9 to 4.7.23. But while database upgrade i got error as "Found installation canary. This suggests that something went wrong with tracking installation process. Please post to forum or JIRA". As I researched, I deleted the table "civicrm_install_canary" but again the table creating dynamically. I didn't get any solution. Please help me.

Thanks in advance.

  • are you upgrading civicrm directly to 4.7.23 ? if yes, 4.2.9 is quite old version, should upgrade it into multiple steps, and take backup at completion of each step. 4.2.9 -> 4.2.recent, 4.2.recent -> 4.4.recent, 4.4.recent -> 4.6.recent, 4.6.recent -> 4.7.23. – Sunil Pawar Oct 11 at 9:13
1

If you're getting an installation canary error, that means you tried upgrading once and it failed - and then when you upgraded a second time, you got the installation canary error. The original error is the "true" error. You can probably ffind it in your ConfigAndLog logs. However, you should restore your pre-upgrade backup before attempting another upgrade. Fixing a broken upgrade is a very advanced topic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.