2

Fresh install of CiviCRM on a WordPress multisite yet no interface loads on the status page - seems that all the assets throw a 404 error causing this.

Tried updating from 5.18.1 to 5.18.2 but no success.

enter image description here

  • At administer - system settings - resource url, what do you have listed there? If it says something like [civicrm.root], click the help bubble at the top (in the intro text area above the settings, not beside the setting description) and it will tell you the real path that it thinks that is. – Demerit Oct 10 at 17:31
2

I'm with Demerit - it looks like there's a mismatch between your Resource URL and your base directory. Check your $civicrm_root in civicrm.settings.php. Ensure that it is a) correct, b) doesn't contain a symlink. If it contains a symlink, rewrite the path to be whatever the symlink(s) resolve to.

  • So I have to edit the plugin manually over being able to use a settings screen or similar?? Seems a bit backwards with having to do this every time I'd update the plugin.... – Chris Butterworth Oct 11 at 9:08
  • The settings file containing the base url isn't updated when the CiviCRM files are updated. So these settings can just be made once – Oliver Gibson Oct 11 at 12:43
  • The civicrm.settings.php is the equivalent of wp-config.php - it doesn't get overwritten on upgrade. Should be a quick fix. – Jon G - Megaphone Tech Oct 11 at 21:11
2

So after looking at this closer and working with a colleague, we found that disabling cache for the assets worked – Status page angular load error

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.