1

After upgrading to 5.17.4 under Joomla, the next large CiviMail job did as follows:

  1. It never completed and had to be cancelled
  2. It reported zero successful deliveries, though it did report opens
  3. At the next cron cycle it resent the same emails.
  4. Some recipients never received emails.

An examination of the ConfigAndLog file showed 'No database selected' errors.

After upgrading to CiviCRM 5.18.2, the 'No database selected' errors went away, but the above issues remained.

CiviCRM reports that the cron job has not run, and the scheduled jobs log shows it not finishing. The cron command is:

wget -q -t 1 'https:///administrator/components/com_civicrm/civicrm/bin/cron.php?name=&pass=&key='

We used to run php cli.php, but that stopped working after the 5.17.4 upgrade.

Has anyone any suggestions as to what might be causing the issue? It is difficult to troubleshoot as it means potentially flooding our contacts with emails.

  • I have done further investigations. Jobs with five or fewer recipients run to completion, while jobs with six or more do not, but instead send to the same recipients with the next cron run. Changing the mail batch size to 5 seems to solve the problem, but it means that large mail runs will take a very long time to complete. – Stephen Palmstrom Oct 17 at 12:07
  • Did you find any further clues about the cause? Are you using Mosaico/Flexmailer and/or Sparkpost? I'm also seeing the mailing job not finishing. – Aidan Nov 18 at 22:20
  • No, but it may be due to PHP setting limitations. The problem occurs on a shared server where we don't have access to critical settings such as max_execution_time. I have development system on my local PC which doesn't exhibit the issue. – Stephen Palmstrom Nov 20 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.