1

Our menu bar is currently missing. We are on WP 5.2.3 and Civicrm 5.15.1 I managed to get CiviCRM Admin Utilities installed and that makes the site workable, but i would like to get the menu working. This is what I currently see. enter image description here I am not sure if I am on the correct track, but I saw on some forums that this could be related to the resource url.

My resource url currently is enter image description here. Is that correct?

I have tried cleaning up the Caches and resetting the paths, but when i reset the paths it says that my civicrm userFrameworkResourceURL is overriden in civicrm.settings.php

My Resource URL is pointing to wp-content/plugins/civicrm/civicrm. My civicrm.settings.php file is sitting in /wp-content/upload/civicrm/civicrm.settings.php.

Is my resource url correct? or what should the Resource url point to?

Sorry for what is probably a silly question, i'm not even sure if this is part of the issue.

  • I've tried and updated the civicrm.settings file to: wp-content/upload/civicrm/civicrm and interestingly while admin console (what I have to use to navigate civicrm without a menu bar) looks different, my menu bar doesn't come back. Also the civicrm pages take significantly longer to load. I then cleared the cache and rebuilt the paths but still, the menu doesn't come back. i have reverted back to wp-content/plugins/civicrm/civicrm for my resource_url. – user7275 Oct 17 '19 at 22:16
  • Could you take a look at Administer/Customize data and screens/Display Preferences/MenuBar position and ensure that your menu bar is not disabled – peterb Oct 20 '19 at 17:01
  • Hi Peter, the menu bar was not disabled. Interestingly enough when I change the menu bar position to 'above content' i see just a text based list of all the menu items, one below the other. But when i have it on the standard below website menu i don't see anything at all – user7275 Oct 21 '19 at 4:23
  • One other thing to try. My resource URL is set to [civicrm.root]/. Note the trailing slash. Does this change make any difference? The civicrm.settings.php file says "IMPORTANT: Trailing slashes should be used on all URL settings." – peterb Oct 21 '19 at 16:22
1

If unsure about settings I normally double check them against the relevant sandbox -> https://wpmaster.demo.civicrm.org/ (or dmaster for drupal).

My post upgrade checks for a missing civicrm menu are:

  1. Clear Caches - Twice
  2. Delete all files and directories inside templates_c (Usually located at directory that [civicrm_files] points at. Unless this is overridden in civicrm.settings.php)
  3. Rebuild Menu's

(Note for wordpress the wordpress civicrm admin utilities you mention provides handy links to these, plus more -> https://wordpress.org/plugins/civicrm-admin-utilities/)

Drupal: http://example.com/civicrm/menu/rebuild?reset=1

WordPress: http://example.com/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fmenu%2Frebuild%3Freset%3D1

Joomla: https://example.com/administrator/?option=com_civicrm&task=civicrm/menu/rebuild?reset=1

(adapted from Joe Murray's answer on How to run triggerRebuild URL)

  1. Check the Browser console for Javascript errors. Extensions (Shoreditch for example) if not kept up-to-date can cause problems if they are overriding files, or expecting specific code that has changed in core. This can lead to the menu not showing. Probably not relevant to you - but for Drupal for example if the setting to combine and compress js files into one is selected then often a completely unrelated error can cause havoc else where. Turn off any aggregation.

Incorrect resource url: This warning is triggered if the following file can't be resolved. "CiviCRM Resource URL"/packages/jquery/css/images/arrow.png (Should be located at https://example.com/wp-content/plugins/civicrm/civcirm//packages/jquery/css/images/arrow.png If you see the "arrows" in you civicrm menu then this is a false positive. If you can't see your menu that doesn't really help sorry. From memory there have been some false positives for this warning in a recent install.

Additionally you possibly want to think about upgrading to the latest version of civicrm as there have been a few security releases since your version was released. As well as being insecure, if you are not running the latest version you run the risk that the problem you are having was a core bug that has since been fixed.

0

I can't say that I know why this is happening, but the menu often disappears for me each time I upgrade CiviCRM to 5.17.x or beyond. I realise your CiviCRM version is a bit older, but perhaps my fix will work for you too:

I find that the CiviCRM menu reappears consistently if I visit the "Settings - Resource URLs" page (which you have a partial screenshot of) and simply hit "Save".

  • That sadly didn't work for me. Thanks for the suggestion though. – user7275 Oct 17 '19 at 21:40
0

I don't know if it helps, but some time between CiviCRM 5.11 and 5.15.1 a new setting for menu permission was introduced with one of the options being "none - disable menu". Its in Administer >> Customize Data and Screens >> Display Preferences, but to get to it you will need to use http://yourdomain.org/wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin%2Fsetting%2Fpreferences%2Fdisplay&reset=1 as you obviously can't use the menu to get there.

Would be useful to know whether it just suddenly disappeared or if this was after an upgrade or something.

0

Your resource URL, 'https://name/wp_content/plugins/civicrm/civicrm
is exactly what I have, and it works. In one case I ended up basically re-installing Civicrm after saving the database, etc. Civicrm complained about 'incorrect resourceUrl' but it worked, I got a menu, built correctly. Re: trailing slash, inside civicrm.settings, civicrm_root will be defined as 'your home folder/name/wp_content/plugins/civicrm/civicrm/' with the trailing slash

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.