0

I've changed the URL of our site from beta.example.net to example.net and now CiviCRM is loading with the Drupal frontend theme instead of it's own.

I've enforced the change by updating the line in .htaccess that's enforcing https. It now reads as

RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://example.net/$1 [R=301,L]

I've also updated the base URL in Drupal's settings.php to

 $base_url = 'https://example.net';

and the site URL in civicrm.settings.php with

if (!defined('CIVICRM_UF_BASEURL')) {
  define( 'CIVICRM_UF_BASEURL'      , 'https://example.net/');
}

I've also tried setting the CMS root in civicrm.settings.php with both

define('CIVICRM_CMSDIR', 'https://example.net/');

and

define('CIVICRM_CMSDIR', '/var/sites/c/example/public_html/');

but neither seems to make any difference.

My best guess was that I'd broken something with Shoreditch, trying at some point in the past to define a relative URL so that CiviCRM wouldn't constantly display an error. But I've gone to https://example.net/civicrm/admin/extensions (I can't navigate to it through the current theme) and disabled Shoreditch and the error is still occurring.

With Shoreditch enabled, this is how the resource URLs screen currently looks: Screenshot of Resource URLs screen

Screenshot of the current state of the extensions page: Extensions page, showing Shoreditch is enabled

And, just to confirm I cleared the cache: CiviCRM reporting cache cleared

Drupal's own backend loads as expected (though somewhat slowly). Drupal 7.67. CiviCRM 5.18.2. Shoreditch 0.1-alpha34.

  • Does a clear cache helps? Go in your browser to your-site/civicrm/clearcache?reset=1 also shoreditch has checkbox under Administer --> System settings --> resource url – Jaap Jansma - CiviCooP Oct 23 at 13:46
  • Cache clear doesn't help. No sign of the Shoreditch checkbox - I've just added a screenshot above. – somnolentsurfer Oct 23 at 15:01
  • There should be a radio button next to custom css. Are you sure shoreditch is enabled? – Jaap Jansma - CiviCooP Oct 23 at 15:10
  • Well it's definitely reporting that it's enabled. Screenshot added. – somnolentsurfer Oct 23 at 15:35
1

I updated CiviCRM, and all seems fine now!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.