3

I am using the latest CiviCRM 5.18.4 and Backdrop 1.15.x-dev all up to date.

I am new to CiviCRM, but have used Drupal 6,7 and 8 over the years. I have been following the excellent documentation, I am sure I have done everything correctly to create a Contribution Page with a profile to allow a visitor to create a CiviCRM Account in the 'host' Group I have created, because when I add a user he/she appears with all the correct data from the profile and in the correct Group, but the user is not added as a Backdrop User.

In the Profile I have 'Drupal User Registration' and 'View/Edit Drupal User Account' checked, so it should work. I have looked all over this forum, and searched extensively on the internet, but cannot find an answer.

I have enabled debugging but there are no errors in the CiviCRM or Backdrop logs. I can add a new user as a visitor in Backdrop, I have tested that. Works fine.

Any help much appreciated. Is it something to do with the Backdrop Permissions? IF so what should those be?

  • Not an answer - but this thread, particularly this comment suggests that some folks have this working under Backdrop. – Jon G - Megaphone Tech Oct 31 at 15:35
  • Thanks for the links. Read this just after I found out how to make it work. – themetman Oct 31 at 16:52
  • 1
    Could you please post your own answer about how you got it to work for others? Thanks, and welcome to Stack Exchange and CiviCRM! There's also help to be found at https:/chat.civicrm.org. – Jon G - Megaphone Tech Oct 31 at 16:58
4

I found out by accident, or trial and error really, that if I select a Price Set in the 'Contribution Page' -> 'Membership Tab' then the new user is not created, but If I do NOT select a 'Price Set' and just the 'Membership Type', then the Backdrop User is created. Now to get that to assign the correct Role is the next task.

  • Add the user to a group via the profile (or CiviRules if you have more complex needs) and then use CiviCRM Group-Role Sync. – Jon G - Megaphone Tech Oct 31 at 16:59
  • I will give it a try, Thanks for the info – themetman Oct 31 at 17:00
  • In fact I found out that the Profile under 'Advanced Settings' has an option to add to a Group, which works. I need to somehow get the new Contact to have a Role the same as the Group – themetman Oct 31 at 17:13
  • Sorry - I wrote my instructions without enough detail for a newcomer, and I apologize! Per Stack Exchange etiquetter, I created a new question for you which I answered. Speaking of SE etiquette, to mark a question "solved", click the checkmark to the left of the appropriate answer. – Jon G - Megaphone Tech Oct 31 at 21:16
  • Thanks again for the detailed explanation in the link. I did click the checkmark, but am not allowed to click my own answer for 2 days. – themetman Nov 1 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.