2

I tried to upgrade version 4.6.3 (Drupal 7.37, dutch) to version 4.6.4. After upgrading the database, [Executed: Upgrade DB to 4.6.4] the process seemed to stop on 2/3 of the bar. After 10 minutes I tried to use CiviCRM and it worked showing version 4.6.4.

There are no errors in the logfile server or on screen, in civicrm.log the normal logging [Executed: Upgrade DB to 4.6.4] and [upgrade:4.6.4.upgrade->4.6.4]

Maybe the problem was that I first tried the upgrade without being signed in on Drupal. After the error I started the upgrade again and it did not completed, but CiviCRM works.

Will this cause problems going forward or am I okay?

1

You can see exactly what queries are being run by this incremental upgrade by opening up the CRM/Upgrade/Incremental/sql/4.6.4.mysql.tpl. In this case it's basically nothing. There is one query in there, which you could copy and paste into e.g. PHPMyAdmin and run it from there (although it honestly doesn't look very important).

Normally I would worry about a hung upgrade and recommend you restore from backups and try again. But in this case I think you lucked out.

  • Thanks, I have checked the sql-statement and it was performed in the upgrade. The grouptype was changed (the grouptype is now as it should be according the sql-statement). – HanV Jun 20 '15 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.