1

I am involved with three CiviCRM instances, a live one under LAMP, Joomla 3.9.13 and CiviCRM 5.18.2, a test one under LAMP, the same Joomla version and CiviCRM 5.18.4 and a development environment running under Windows 10, IIS, the same Joomla version and CiviCRM 5.18.4. The live environment is OK, the development environment is OK, but cron jobs are not running in the test environment. The PHP log file gives these two errors:

[07-Nov-2019 19:05:30 Europe/London] PHP Warning:  ini_set(): A session is active. You cannot change the session module's ini settings at this time in <joomla_root>/libraries/joomla/session/handler/joomla.php on line 48
[07-Nov-2019 19:05:30 Europe/London] PHP Warning:  session_cache_limiter(): Cannot change cache limiter when headers already sent in <joomla_root>/libraries/joomla/session/handler/native.php on line 235

The command line is:

wget -q -t 1 'https://<example.com>/administrator/components/com_civicrm/civicrm/bin/cron.php?name=<user>&pass=<password>&key=<key>'

I've tried clearing the session table, but it hasn't helped. Debugging is difficult - I've tried the error_log() function to track what is happening, but not very successfully; PHP doesn't always write to the log file.

Can anyone suggest where I should look? I hesitate to update the live environment until the test environment is working properly.

1

I had difficulties getting cron.php to log progress and, as the issue was on a remote server would have difficulties debugging. As a consequence, I rolled the CiviCRM installation and database back to backups taken before the issue occurred, and then reinstalled the CiviCRM upgrades. The cron job now appears to be working. Fortunately, the problem was on a test system so it didn't matter about any recent work. Had it been on a live system, it the issue would have been much more serious.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.