2

I'm considerably confused about what's happening with Mailer & images (initially, I thought the problem was related to Mosaico, but it's now disabled): weirdly, I can upload an image to a newsletter draft -- and see it there, in the draft . . . but I cannot see it with KCFinder. I can't see anything at all in KCFinder, and it spits error messages back when I try to navigate to subfolders.

The image directory is: [civicrm.files]/persist/contribute/

Indeed, uploaded images (from either Mailer or Mosaico) land happily in this directory, but I can't view or use them from within CiviCRM.

Been reading related issues for days, and I can rule out imagick (specifically related to Mosaico) & permissions (settings are normal, at 755 for directories and 644 for the images themselves). Any insight would be most appreciated!

CiviCRM:5.19 WordPress: 5.2.4 PHP: 7.1enter image description here

  • Interestingly I've found similar that when I try to browse images when composing a email (not with mosaico) it opens kcfinder in a new window and freezes everything up, I lose all unsaved data. I'm on 5.18.4 though – netzih Nov 10 at 6:47
  • Also tried changing the default editor to TinyMCE. No difference in behavior -- I can still upload without problem. In the CiviMail interface, I can see the uploaded images in the newsletter draft (and these also send without any problem). But I still can't browse them in KCFinder. (In Mosaico, I can't see them on the draft newsletter at all, but they do upload successfully from there). – mc_burger Nov 13 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.