I installed Drupal 7 and when I try to add the civicrm (version 5.19.1) module into it, I get next error message on the web interface of Drupal:

Unable to extract symbolic link {temporary://update-extraction-0a20b282/civicrm/vendor/pear/log/README.rst}

and the module is not installed. I would like to know how to solve this.

  • The tar.gz archive contains a broken symbolic link: civicrm/vendor/pear/README.rst pointing to an unexisting docs/guide.txt file. Commented Nov 14, 2019 at 13:30
  • Are you following the instructions at docs.civicrm.org/sysadmin/en/latest/install/drupal7 ?
    – Demerit
    Commented Nov 14, 2019 at 20:59
  • Yes. Where I have the alternative, I choose: "As administrator in Drupal, go to Modules, click on Install New Module , and it will ask you to fill in the URL of the module. It will then fetch it and install it for you". Commented Nov 14, 2019 at 21:23
  • I'm getting the same error in 5.19.3 upgrade install: tar: civicrm/vendor/pear/log/README.rst: Cannot create symlink to 'docs/guide.txt': No such file or directory tar: Exiting with failure status due to previous errors Is there a work around?
    – Larry Lowe
    Commented Nov 29, 2019 at 18:23
  • Yes, the workaround is to upgrade from the command line interface and to extract the files from the tar.gz achive. If you don't have access to the hosting system with the shell, extract the tar.gz archive on your own desktop/laptop, remove the offending civicrm/vendor/pear/log/README.rst symbolic link and copy the remaining extracted files to the remote directory. Commented Nov 30, 2019 at 10:00

1 Answer 1


UPDATE: This is now fixed in 5.31.

I see what you're saying. Thanks for reporting. I've never used that alternative before. I believe it's coming from this line where it excludes the docs folder so the symlink is no longer valid.


I've made a ticket at https://lab.civicrm.org/dev/core/issues/1393

  • So, it is a bug. Commented Nov 15, 2019 at 6:28
  • Is there an update on this problem? I am trying to install CiviCRM 5.23.0 on Drupal 8.8.3 and I get the same error message
    – gebseng
    Commented Mar 5, 2020 at 14:42
  • You can't install civi on drupal 8 from that screen anyway. Drupal 8 requires using composer.
    – Demerit
    Commented Mar 5, 2020 at 15:12
  • sorry and thanks!
    – gebseng
    Commented Mar 6, 2020 at 17:51
  • @gebseng - re progress: you can check by following the link above to the issue ticket. So far, no progress has been recorded.
    – Aidan
    Commented Mar 6, 2020 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.