3

I'm testing through migrating from joomla to wordpress. My developemnt site is set up in Wordpress 4.2.2 and Civi 4.6.3. I'm having an issue with contributions, when you make a contribution the thank you page is skipped and the user is dropped back to the original contribution page (it's blank, like it redirects there.) The contribution is successful and an email is sent so I'm at a loss for what is happening.

I've checked the civi log and the error log, there's nothing there. I also tried to reproduce it on the demo site, no dice. I've turned off all plugins in wordpress and removed my custom php file.

The one thought I have is that all my urls seem to be using &2f rather then the forward slash for any "/" that occur after the "?page=CiviCRM" . I was thinking it might be a related problem since the URLs works with checksums??

Any idea what else I can do to solve this!?

3

So I finally figured out what was causing this - but it created another small hiccup. In Wordpress' theme customizer if you set any sort of static front page that's when things start breaking. I tested a bunch of different pages, the civiCRM page that is set as the base page, a page with a contribution on it overridden content and non-overridden. All these pages had the same result - the thank you page on civi generated donate links doesn't show up. (I also tested different themes, it wasn't theme based.)

But.....if you show a lists of posts as your home page the thank you page does show up! Which works for now but is problematic as you can't publish more than one post ever. If you only have one post published it shows the whole post on the home page. Once you have more than one it shows excerpts - which for me is awkward. I like my home page to be a donation page.

I couldn't reproduce this on the demo server as we (understandably) don't have access to the Wordpress settings. I'd love some feedback if I'm the only one who has noticed this or if anyone has found a workaround.

2

Ray - fwiw I am trying this out on my test system- WP + older CiviCRM - the urls are formed using &2F rather than /, but I do get the 'Thank you' page. On your Thank you page, did you check 'send email' (maybe uncheck?) Are you using 'test drive'-assuming you are -maybe a problem w/payment processor, are you using Dummy/test payment processor, only after confirmation will it hit the pmnt processor.

  • Good points! I am using a Dummy Payment Processor and have it set to send an email. I did try turning off send email and a live payment processor. Still no dice, it completes the trnx but skips back to the main page contribution page rather than the thank you page. I should mention that when you run a test trnx you do get the thank you page. – RayWright Jun 22 '15 at 15:33
  • 'Test drive' as opposed to 'live, you mean? sounds like an issue w/payment proc. only b/c that is the difference, as far as I know, btwn 'test' and 'live' - when you're really 'live' you need a security cert which no doubt you have from your Joomla setup, but - in your Dummy processor setup, did you set up Dummy details for Live Processor as well as for Test payments? (name, dummy.com.. ) and make the Dummy your default payment processor? – Lesley Evensen Jun 23 '15 at 18:59
  • Yes, I've tried both payment processors a live one with security creds and the dummy processor (dummy.com) - with the same results for both. I should say it also skips the Thank you page when you elect to 'pay later' which leads me to believe it is not the payment processor. – RayWright Jun 25 '15 at 19:15
2

I ran into this problem too when I upgraded CiviCRM.

I was also having trouble with the "Thank You" pages for registering. Like this question. And the fix for that, setting the wordpress base page fixed the problem. Full details are available in this answer

After following those instructions, it fixed this problem too.

0

Just create a Thank you page against Wordpress and use that page while re-directing this will solve the issue

  • I'm not sure this would help, I have no idea why/how it's skipping the thank you page and 'redirecting' to the original donation page to begin with. Plus then the donor would miss out on all the confirmation information contained on the thank you page. – RayWright Jun 19 '15 at 18:52
0

@RayWright With or without the Wordpress Base Page set in civi: add the following to your functions.php:

function turnoff_front_page_redirect( $redirect_url ) {
    if ( is_front_page() ) $redirect_url = false;

    return $redirect_url;
}

add_filter( 'redirect_canonical', 'turnoff_front_page_redirect' );

Worked like a charm. -Carlos

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.