0

Running on Drupal 7.67

Running the DB upgrade from 5.14.1 to 5.15.0 stalls on 'Update smart groups where jcalendar fields have been converted to datepicker', and afterwards retrying or reloading Civi shows same as error as the ConfigAndLog shows at the bottom:

Nov 17 12:58:43 [info] Running task: Cleanup old files

Nov 17 12:58:44 [info] Running task: Checking extensions

Nov 17 12:58:44 [info] Running task: Begin Upgrade to 5.15.alpha1

Nov 17 12:58:45 [info] Running task: Upgrade DB to 5.15.alpha1

Nov 17 12:58:46 [info] Running task: Upgrade DB to 5.15.alpha1: SQL

Nov 17 12:58:47 [info] Running task: Fix errant deferred revenue settings

Nov 17 12:58:47 [info] Running task: Fix cache key column name in prev next cache

Nov 17 12:58:48 [info] Running task: Update smart groups where jcalendar fields have been converted to datepicker

Nov 17 12:58:48 [info] Running task: Finish Upgrade DB to 5.15.alpha1

Nov 17 12:59:04 [info] $CRM_Queue_ErrorPolicy_reportError = Array ( [is_error] => 1 [is_continue] => 0 [exception] => Error 64: Cannot make non static method CRM_Core_DAO::copyCustomFields() static in class CRM_Event_BAO_Event in /home/tamera/www/dev/sites/all/modules/civicrm/local/code/CRM/Event/BAO/Event.php, line 2387 [last_task_title] => Finish Upgrade DB to 5.15.alpha1 )

Any ideas?

  • Are you upgrading just to 5.15 or are you trying to upgrade to something higher and that's just where it stalls? What version are the actual code files that you have installed? – Demerit Nov 17 '19 at 14:57
  • I've tried to upgrade to the latest 5.19.1 and got this error, and then I thought I would try in steps, and went only for 5.15.0, and it still happens. – Elad Nov 18 '19 at 17:16
  • 1
    Do you have a custom php directory set up at administer - system settings - directories and do you have a customized version of CRM/Event/BAO/Event.php? The reason I'm asking about version is the line number doesn't match up and also copyCustomFields was moved in 5.15 so if you still have a reference in Event.php to self::copyCustomFields from 5.14 or earlier, it would now end up trying to call the base class CRM_Core_DAO as described in the error. – Demerit Nov 18 '19 at 17:24
  • Yes, and YES! Thank you, that was spot on! – Elad Nov 20 '19 at 15:35
1

As per comments this was caused by a customized Event.php file in the custom php folder set at administer - system settings - directories.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.