2

Its quite confusing. The default payment method is check. When someone says they are paying later - it can be a multitude of payment options. When we record the payment - it still shows the main payment method as check - even though its something else - how can we change that. (besides heading into the back end.)

This mostly impacts how we report payment methods and search for payments.

  • I thought we had found a workaround - ie on a site i see we created a new Payment Method called Unknown - but i can find no evidence that front end 'pay later' ones are being set to this, so perhaps only for back end. but I agree it is nuts that Pay Later ones are recorded as Check when we have no idea! – petednz - fuzion Nov 19 '19 at 5:32
  • I think this would be the same problem i highlighted some time ago (civicrm.stackexchange.com/questions/33466/…) however, it seems to be a bug that is being looked at. – Clement Leong Nov 20 '19 at 13:23
2

I also found that workaround! This is an ongoing pain point, see https://lab.civicrm.org/dev/financial/issues/37 for a related issue.

In short - until a few years ago, a Contribution record was just that - a contribution. Now it's more of an "obligation to pay", and Payment records are where the actual money is recorded.

So "payment method" (and "check number") don't belong on contributions - they belong on payments. Until this is fixed, your workaround is as good as it gets. Fortunately, there's general agreement on this direction, and the financial subsystems are currently being rewritten to make future changes easier and more testable.

| improve this answer | |
1

Looks like you can do this without touching the database directly. I dont think this was an option before.

  1. create a profile with payment method as a field
  2. Run a search for those contributions you want to update.
  3. select the contributions - under actions - select update multiple contributions
  4. Select the profile you created and update the contributions with the correct payment method.

This still does not resolve the general issue but is a workaround. Another thing we did was change the default payment method to the most popular pay later option, that helps.

| improve this answer | |
  • Note also that this is an area of active work - I expect this to be resolved in 5.20 or 5.21, since all code paths to pay a contribution shoudl be merged. – Jon G - Megaphone Tech Nov 30 '19 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.