1

I am using CiviCRM on Backdrop (Drupal 7). I am new to CiviCRM, but not new to Drupal.

I have read the CiviCRM documentation on Groups, Profiles,etc. Well all of it pretty much. Also read old an new posts about Accounts and Roles and Profiles. I am pretty sure I have everything set up correctly.

I have a CiviCRM Profile used for new user registration which works fine. It is creating the Backdrop Roles, Civi Group and Membership Type as I want.

Logging in as the new user having got a password sorted, there is no sign of the Civi Profile or a link to it on the User Account Page. In the Profile Settings I have checked the 'View/Edit Drupal User Account [ x ] CiviContribute' field so it should show up.

I have unchecked the Backdrop Permisssions for 'access all custom data' and in the Civi ACLs I have tried setting both 'A profile' and 'A set of custom data fields' in the 'Type of Data' but no go. The Profile is not seen on the Account Page. Even when logged in as the Administrator I cannot see this data on a user's accounts Page.

I must be missing something here, but what?

  • my first guess is this would be permissions issue. does it work for user/1 ? "I have unchecked the Backdrop Permissions for 'access all custom data' - i would expect that does need ticking – petednz - fuzion Nov 26 '19 at 1:40
  • also worth clarifying what sort of fields are in the profile. it would ONLY work if they are Contact fields, not eg Contribute fields – petednz - fuzion Nov 26 '19 at 1:41
  • As I said above it does not work for User/1 (Administrator) Most fields are from a Custom Field Set. The Drupal Permissions override CiviCRM ACLs so somewhere I read that if you are going to use the Civi ACLs then uncheck the Drupal Permissions. I will try without the ACLs later today and see what happens – themetman Nov 26 '19 at 7:15
  • Nope, Does not work. Disabling ACLs and using Drupal Permissions and the reverse. In this section of the documentation here it clearly says you use ACLs to access sets of custom data fields. So it mus be possible. I have added ACLs to allow the group to View and Edit both the Profile and the Custom Field Set, but it is still not seen. – themetman Nov 26 '19 at 8:03
  • Your question doesn't mention ACLs. There is no reason i can see in what you are needing to have any ACLs involved. This should be purely a case of 'set up a Profile using only Contact fields, set it to show for User Create, set Permissions for custom fields, Profiles, etc'. I have never used Backdrop but would expect it to work as D7. Only thing i think i can offer is a link to a set of Permissions that should work for you but if you are user/1 (and assuming user/1 in Bdrop+Civi confers all powers, then seems it must be some other oddity. – petednz - fuzion Nov 26 '19 at 17:54
1

I would check what is happening by setting up a Profile with the simplest possible profile eg just First and Last and Email

That will help rule out the issue being related to any of your Fields or permissions related to eg Custom Fields.

  • As you have suggested I created a new profile and started with simple fields from Individual and Contacts. This worked. The profile appeared in a user's Account for viewing and editing. As soon as I added a Custom Field, even a simple text one, the Profile disappeared from the User Account Page. I think I will take up something easier than this, perhaps Tiddlywinks... – themetman Nov 28 '19 at 8:43
  • if the Profile stops showing as soon as you add a simple Contact-based text field (not participant or contribution or event or any other type of field) then the next thing to look at is the CMS permissions but I take it from your comment earlier that you do have the Custom Data permission set on. – petednz - fuzion Nov 28 '19 at 18:41
  • Yes I do have the premissions set in the ALCs – themetman Nov 28 '19 at 22:33
  • I said earlier that IMO this has nothing to do with ACLs - it is CMS permissions - but maybe in Backdrop speak it is the same thing - but in Drupal it is User Permissions - not CiviCRM ACLs - it may just be a language confusion - but this should be really easy, and if it isn't then i suspect you have something simple set incorrectly – petednz - fuzion Nov 29 '19 at 2:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.