When trying to send a test mailing, the preview and test email box appears to be improperly drawn and the "Send Test" button doesn't appear to work. I tried upgrading CiviCRM (from 4.6.2 to 4.6.4) but the problem persists.

CiviCRM 4.6.4, Wordpress 4.2.1, Apache 2.4, PHP 5.6.9-1, Mariadb 10.0, Debian Wheezy/Sid hybrid

I notice this was an issue in the beta forums previously http://forum.civicrm.org/index.php/topic,33598.msg142461.html#msg142461

Any ideas how to fix it?


  • Which browser are you using? A trick I try is to "Inspect element" or similar. Then the "web developer debugger" will show any problems in the HTML/CSS. I find that the CMS-template sometimes seems to screw up things like this. – thoni56 Jun 19 '15 at 9:37
  • 1
    They look like disabled buttons to me. Are you sure that you've completed all the required fields? – choster Jun 19 '15 at 14:05
  • Agree with above, scrolling up on the page may show the 'message' such as 'zero contacts' or 'missing token'. – petednz - fuzion Jun 21 '15 at 20:33

They are disabled. Notice that the "Next" button is also disabled. This means that you have not completed all required fields for your mailing. Please review that you have:

  • A subject
  • Recipients
  • Content
  • Required 'opt out' tokens

They're disabled because you haven't completed all the required actions yet.

Have you remembered to include the the mandatory address and opt-out tokens in the body of your email?

You need to include:


And at least one of the following:



The other thing to check is that you have a mailing list selected. It's silly but CiviMail requires one even when you're just sending a test to a single email, so it's worth having a generic 'test' mailing list set up for this purpose (that you can then replace with the 'real' mailing list before you send).


I found a few more situations that the greyed out button can appear which may be less than obvious

  • if there is no Resubscribe Msg set on the Response tab (no alert is currently provided

  • if you put in a Subject, but then decide to switch to using a Template that has no Subject set

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.