1

Drupal 6.36; CiviCRM 4.5.8

I am experiencing two problems after making changes to my site. Not sure if the problems are related. I will start troubleshooting but any guidance would be very helpful.

1. Civi dashboard loading icon spins and dashlets don't load. This may be related to us installing Cloudflare (http://forum.civicrm.org/index.php/topic,27176.msg142612.html#msg142612).

2. Relationships tab generates error on click. Screen loads but the relationships list doesn't open. The following two popups appear:

DataTables warning: table id=DataTables_Table_0 - Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1

DataTables warning: table id=DataTables_Table_1 - Invalid JSON response. For more information about this error, please see http://datatables.net/tn/1

Clicking the Add relationship button opens the dialogue and allows it to be completed, but on saving the above errors appear again.

Background:

  • Moved the site to a faster server with no apparent problems
  • 6 hrs later...
  • Upgraded Drupal 6.36 security release. All seems fine.
  • Tried to install Civi4.6.4 but it errored out so I reverted to the 4.5.8 backup. It was late and I didn't copy the error :-(
  • Implemented Cloudflare. Civi is appreciably faster. Cloudflare needs www. domains so I set up a redirect in htaccess and updated the Civi paths and resource URLs. Also cleared all caches

Thanks Davy

3

Disabling Cloudflare or switching off popups as suggested didn't help. Neither did setting up a Cloudflare PageRule to bypass all Civi pages

But this worked:

I followed the instructions here (http://wiki.civicrm.org/confluence/display/CRMDOC/Ensuring+Schema+Integrity+on+Upgrades) to clean up my database schema, and then the upgrade to 4.6.4 worked - and fixed the problems.

0

First (and easiest to do) disable Cloudflare and see if the site operates correctly. Disabling Cloudflare is super easy to do.

This may be related to the pop-up forms in recent versions of CiviCRM. You can go to civicrm/admin/setting/preferences/display and unselect "Enable Popup Forms" and see if that corrects the problem as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.