0

I have a contribution page here https://flbc.edu/donate/flbc-donation/, but when I click on confirm it just brings me back to the same initial page. It was working before and I just upgraded to the newest Civi and now it is not working. Any ideas why this might be happening?

  • What payment processor are you using? What do the logs say there? I had a similar issue with the same payment processor interface that you seem to have in place where it couldn't handle the 'do_not_honor' code ebing returned by Stripe and simply went back to the beginning rather than offering a useful error. – Keith Nunn Dec 2 at 23:05
0

When reproducing your experience, I see:

flbc.edu/:1 Uncaught SyntaxError: Unexpected token '<'

Which is weird, since it seems to be loading your whole page as javascript.

It shows it on the initial page load as well as after submitting. And the province selector after selecting a country is also broken, that's probably a symptom of the same problem.

When I look at the html source of your page, I notice that it ends with:

<script type='text/javascript' src='https://flbc.edu/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js'></script>

That's bad - you're not getting your closing html or body tags output.

Conclusion: I suspect you might be hitting some kind of server limit (your page has a lot of css/js loaded).

Do look at your server logs, there's probably a hint in there. I don't think it's CiviCRM-specific.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.