1

I've been able to setup and configure Omnipay using Paypal checkout without issue.

However, I seem unable to use it with Civicrm webform to take membership payments.

The only reference to it can find is a comment on the announcement post in July that there are issues with it, does anybody have anymore information on support for it?

https://civicrm.org/blog/eileen/announcing-paypal-checkout

Thanks in advance for any help or workarounds.

  • So you've tried to set up a contribution form presumably? And what can you see on that? Can you elaborate? – Joe McLaughlin Dec 12 '19 at 19:54
  • When you get to the payment form it hits a JS errors as it seems unable to find values for CRM.vars.omnipay.client_id and CRM.vars.omnipay.currency. I can't see these are set anywhere in the code. I still need to do some more digging but time limited. I need to rule out any customisations etc. – EagleUK Dec 17 '19 at 11:23
  • OK and you've looked here for an existing Issue or filed a new Issue? - github.com/eileenmcnaughton/nz.co.fuzion.omnipaymultiprocessor/… – Joe McLaughlin Dec 17 '19 at 19:01
  • OK right, an Issue already filed, at github.com/eileenmcnaughton/nz.co.fuzion.omnipaymultiprocessor/… – Joe McLaughlin Dec 17 '19 at 19:06
  • Thanks @JoeMcLaughlin, been a bit tied up. Does seem like it's an on going issue, I'll keep an eye on the issue and work around it for now :). – EagleUK Dec 19 '19 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.