3

In upgrading to 5.20+ an error occured while running the database Case upgrade scripts.

Deletion Error There is a Payment Processor associated with selected Payment Processor type, hence it can not be deleted.

CiviCRM_API3_Exception: "API error: Could not delete payment processor type"

#0 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Incremental/php/FiveTwenty.php(370): civicrm_api3("CaseType", "create", (Array:9))
#1 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Incremental/php/FiveTwenty.php(289): CRM_Upgrade_Incremental_php_FiveTwenty::_processCaseTypeLabelName(FALSE, "7")
#2 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Incremental/php/FiveTwenty.php(265): CRM_Upgrade_Incremental_php_FiveTwenty::_changeCaseTypeLabelToName(FALSE)
#3 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Queue/Task.php(88): CRM_Upgrade_Incremental_php_FiveTwenty::changeCaseTypeLabelToName(Object(CRM_Queue_TaskContext))
#4 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Queue/Runner.php(217): CRM_Queue_Task->run(Object(CRM_Queue_TaskContext))
#5 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Queue/Page/AJAX.php(52): CRM_Queue_Runner->runNext(TRUE)
#6 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Queue/ErrorPolicy.php(106): CRM_Queue_Page_AJAX::{closure}()
#7 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Queue/Page/AJAX.php(54): CRM_Queue_ErrorPolicy->call(Object(Closure))
#8 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(250): CRM_Queue_Page_AJAX::runNext()
#9 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(84): CRM_Core_Invoke::runItem((Array:13))
#10 /dir/wp/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php(52): CRM_Core_Invoke::_invoke((Array:5))
#11 /dir/wp/wp-content/plugins/civicrm/civicrm.php(1465): CRM_Core_Invoke::invoke((Array:5))
#12 /dir/wp/wp-includes/class-wp-hook.php(288): CiviCRM_For_WordPress->invoke("")
#13 /dir/wp/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters("", (Array:1))
#14 /dir/wp/wp-includes/plugin.php(478): WP_Hook->do_action((Array:1))
#15 /dir/wp/wp-admin/admin.php(254): do_action("toplevel_page_CiviCRM")
#16 {main}
5

This looks to be a problem with an entity_type row of PaymentProcessorType in the civicrm_managed table.

To show the offending row: select * from civicrm_managed where entity_type='PaymentProcessorType';

Remove the offending row: delete from civicrm_managed where entity_type='PaymentProcessorType';

Then re-run the upgrade.

After the upgrade was re-run, I had to re-add the offending row for the 'ExtenededReports' extension added reports to show up. Installing the 'CiviCRM Log Viewer' extension without this line also gave the same error of database record already exists. In this instance, this is dealing with a record from the extension 'Authorize.net eCheck.Net'.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.