2

I recently moved to a new webhost with Drupal 7 and upgraded to CiviCRM 5.21.0. Everything seems to be working fine, I have no errors in the Administration Console. However, when I go to cases, and I reassign a case role, I get an error:

"DB Constraint Violation - membership_contact_id should possibly be marked as mandatory for Membership,get API. If so, please raise a bug report."

I don't even have CiviMember or CiviCampaign enabled. I ran the upgrade script again, no issues. I disabled and re-enabled CiviCase again. Clear cache, deleted everything in template_c. I don't know what else to try. Any ideas?

2
  • What extensions do you have installed? – Demerit Jan 6 '20 at 13:48
  • Summary Fields, Related Permissions Module, CiviRules – Kristine Jan 6 '20 at 19:09
2

Based on chat discussion there was a missing database field for unknown reasons. Running this helped:

ALTER TABLE civicrm_membership ADD COLUMN status_override_end_date date DEFAULT NULL COMMENT 'Then end date of membership status override if ''Override until selected date'' override type is selected.';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.