1

While the Mailchimp extension does appear in my list of "Manage Extensions", when I click Install, I get an error stating:

Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred. DB Error: already exists

There is no other entry in my extensions for Mailchimp, so I can only assume it refers to itself. I've tried going in to wordpress\wp-content\uploads\civicrm\ext and deleting the uk.co.vedaconsulting.mailchimp folder. While this does remove it from my "Manage Extensions" list, if I add it as a new extension and install it, the same error occurs.

CiviCRM 5.19.2 (will be updating to 5.21.0 in Feb)

Wordpress 5.3.2

EDIT:

I've ran the same process with Debugging and Traceback enabled and get the following errors. Should be worth noting I'm running Civi on a local WAMP server, might have nothing to do with that but that explains the directory paths.

CiviCRM_API3_Exception: "DB Error: already exists"

#0 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Admin\Form\Extensions.php(189): civicrm_api3("Extension", "install", (Array:2))
#1 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Form.php(495): CRM_Admin_Form_Extensions->postProcess()
#2 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\StateMachine.php(160): CRM_Core_Form->mainProcess()
#3 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\QuickForm\Action\Next.php(61): CRM_Core_StateMachine->perform(Object(CRM_Admin_Form_Extensions), "next", "Next")
#4 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\HTML\QuickForm\Controller.php(203): CRM_Core_QuickForm_Action_Next->perform(Object(CRM_Admin_Form_Extensions), "next")
#5 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\packages\HTML\QuickForm\Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Admin_Form_Extensions), "next")
#6 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Controller.php(351): HTML_QuickForm_Page->handle("next")
#7 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Page\Basic.php(411): CRM_Core_Controller->run()
#8 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Page\Basic.php(156): CRM_Core_Page_Basic->edit(1, NULL)
#9 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Admin\Page\Extensions.php(121): CRM_Core_Page_Basic->run()
#10 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(290): CRM_Admin_Page_Extensions->run((Array:3), NULL)
#11 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(84): CRM_Core_Invoke::runItem((Array:16))
#12 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(52): CRM_Core_Invoke::_invoke((Array:3))
#13 C:\wamp64\www\wordpress\wp-content\plugins\civicrm\civicrm.php(1441): CRM_Core_Invoke::invoke((Array:3))
#14 C:\wamp64\www\wordpress\wp-includes\class-wp-hook.php(288): CiviCRM_For_WordPress->invoke("")
#15 C:\wamp64\www\wordpress\wp-includes\class-wp-hook.php(312): WP_Hook->apply_filters("", (Array:1))
#16 C:\wamp64\www\wordpress\wp-includes\plugin.php(478): WP_Hook->do_action((Array:1))
#17 C:\wamp64\www\wordpress\wp-admin\admin.php(254): do_action("toplevel_page_CiviCRM")
#18 {main}
 Sorry, due to an error, we are unable to fulfill your request at the moment. You may want to contact your administrator or service provider with more details about what action you were performing when this occurred.
DB Error: already exists
Return to home page.
  • It sounds like there's a problem resulting from an improper uninstall - but there are other possible explanations. To troubleshoot better, go to Administer menu » System Settings » Debugging and Error Handling and enable both debugging and backtrace. Then, repeat the process that gives you the error, and the error will be much more detailed. Edit this question to include both the expanded error and the backtrace and you should get much better answers. – Jon G - Megaphone Tech Jan 9 at 19:54
  • Thanks for the tip, I've updated the question with the detailed error. – joxley Jan 13 at 9:49
  • Could you please paste as text rather than image? It makes it easier for me to copy/paste to search the codebase, and makes it possible for folks who have your problem in the future to use search engines to find this text. – Jon G - Megaphone Tech Jan 13 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.