The dashboard when I log in to CiviCRM does not render, it just continues to say "loading". I have tried:

  • refreshing dashboard
  • reconfiguring dashboard
  • going to another page and coming back to dashboard.

I can't see any obvious errors in the javascript console in Firefox (firebug) or Chromium. There are no errors in the apache logs either.

enter image description here CiviCRM 4.6.4, Wordpress 4.2.1, Apache 2.4, PHP 5.6.9-1, Mariadb 10.0, Debian Wheezy/Sid hybrid

  • Note: As of CiviCRM 4.7.11 and higher, these answers no longer apply. A permanent improvement was made to eliminate the problem that the answers below refer to. Apr 24, 2018 at 22:11

4 Answers 4


A few things may cause issues like this.

Webserver cannot make HTTP(s) requests to itself

If CiviCRM / PHP cannot make a request to the CiviCRM site itself, it will be unable to retrieve the dashboard data. This can happen for multiple reasons:

  • Webserver is behind a proxy and proxy does not permit requests from internal network
  • Webserver has DNS which won't deliver request to the webserver
  • Webserver is not permitted to make HTTP requests
  • Webserver fails SSL negotiation (PHP5.6 requires a valid certificate chain installed, see note below)

Misconfigured base URL / access URL

CiviCRM requires a single configured canonical base URL, and it might be that if this doesn't match the URL you're using then CiviCRM won't handle the dashboard requests correctly. Check that the value defined for CIVICRM_UF_BASEURL in your civicrm.settings.php corresponds to the URL you're using - including both schema (http:// or https://) and hostname (example.org or www.example.org).

Because this can cause various issues, I recommend setting up an automatic redirect to prevent visitors viewing the site via the "wrong" URL (which will appear to work fine, except when it doesn't). See your webserver's documentation for how to do this - I think both Drupal and WordPress .htaccess files contain example rewrite snippets?

PHP5.6 and SSL sites

A few reports are surfacing of the changed default in PHP v5.6 affecting sites ability to connect to themselves (and to CiviCRM.org). In addition to having your SSL certificate correctly installed, PHP requires a correctly installed certificate chain to connect to SSL sites (including the local site). If your CA chain is outdated on the webserver, this may lead to failed dashboard and other issues when communicating with remote sites using SSL (payment processors, CiviCRM.org, and local requests such as dashboard widgets and API over HTTP).

  • See also Dashlet refresh can crash server but I don't think that's your problem. Jun 22, 2015 at 1:44
  • Thanks, the problem was that the civicrm wordpress install is behind a varnish proxy and the local DNS response to the domain was incorrect.
    – FGiorlando
    Jun 27, 2015 at 11:11
  • how can this be resolved if the dashboard doesn't load only to some users? All the Drupal users have contact records in CiviCRM
    – Kboy
    Apr 12, 2016 at 8:47
  • At a guess @Kboy that might affect specific users if their permissions granted them access to a dashboard which took overlong to render. Once I was confident the issue affected users differently, I'd continue debugging by inspecting your webserver logs and seeing which dashboard reports are rendered for the affected and unaffected users. Apr 12, 2016 at 8:49
  • thanks @ chris, i'm getting this error from certain users: $Fatal Error Details = Array ( [callback] => Array ( [0] => CRM_Core_Error [1] => handle ) [code] => 0 [message] => [mode] => 16 [debug_info] => [type] => PEAR_Error [user_info] => [to_string] => [pear_error: message="" code=0 mode=callback callback=CRM_Core_Error::handle prefix="" info=""]
    – Kboy
    Apr 13, 2016 at 12:57

This can also happen if you have an authorised CiviCRM user who does not have a contact record i.e. you haven't sync'd users to contacts. I've only seen this where Drupal was the CMS, but it was 100% reproducible.


I faced this issue and had to reinstall (not duplicate) the wordpress site using the following procedure: 1. exported content using wordpress export 2. copied theme folder and uploads 3. clean install of wordpress 4. install civicrm 5. enabled theme 6. import of content

This was not due to active plugins. Something must of become corrupted in WordPress.


Just FYI, I had a problem where my dashlets would not load after upgrading from Apache 2.2 to 2.4. We have https with a certificate from Comodo and the problem was that our security certificate was no longer installed correctly after the upgrade, somehow causing Civi not to be able to load the dashboard.

Browsers were still recognizing the certificate, so at first I didn't know there was a problem with the certificate. I needed to move the chain/bundle certificates over to the main SSLCertificateFile file (chain file certificates were deprecated in Apache 2.4). As soon as I fixed the certificate and reloaded Apache, back came the dashboard!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.