1

I'm on Drupal 7.67 and using IATS extension 1.7.0, While attempting to upgrade Civi from 15.17.4 to 5.21.0 the upgrade script gave me "API error: Could not delete payment processor type" My search of Stack Exchange questions found two that seemed similar to my difficulty. However, corrective actions seemed to go in a couple of different directions and involved the Civicrm tables "civicrm_payment_processor_type" and "civicrm_managed". In the Civicrm_managed table I found three "payment processor types. I'm wondering if I deleted those three payment processor types and than ran the upgrade process again, would this result in a clean upgrade. (I exported the entire "civicrm_managed" table so I could reconstruct those deleted entities if needed.) However, I have one other possible option. Can I disable the IATS integration module, then run upgrade and renable the module when (and if the upgrade suceeds)?

1

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.