1

I am using Local by Flywheel which connects to MySQL with sockets. My socket is:

/Users/efc/Library/Application Support/Local/run/Qv8NIbiue/mysqld.sock

The MySQL server is localhost, database is local, and both username and password are root (and this really is a root account, I can even create new databases with SequelPro).

When I try to install CiviCRM 5.21.1 on WordPress 5.3.2 I get the error "Can't find the a MySQL server on 'localhost'.: The server requested authentication method unknown to the client" on the "Does the server exist?" line of the CiviCRM Installer screen. Oddly enough, every other item in "CiviCRM Database Details" is "OK" (green). In other words, even though it thinks it can't find the server, it seems to be able to do every other thing OK.

I cannot figure out how to tell CiviCRM what it needs to know to be happy about the MySQL server. How can I make this WordPress install work with sockets?

If I try to put "localhost:/Users/efc/Library/Application Support/Local/run/Qv8NIbiue/mysqld.sock" in the MySQL server field, then "Does server exist" is "OK" but almost everything else goes red.

Note, there are answers to similar questions for folks who have come far enough along in the install process to have a civicrm.settings.php file. But at this stage of the WordPress version's bootstrap it has not yet successfully installed, there is no settings file. This question is about how to respond to this error so that the WordPress version of CiviCRM can be installed in the first place.

  • Sorry didn't see this from Demerit - posted same thing as an answer – Parvez Saleh Jan 22 at 0:51
  • @parvez-saleh No worries - sometimes I wish stackexchange was more like the old forums. – Demerit Jan 22 at 2:17
  • I'm really interested in learning how to do this in the WordPress install of CiviCRM, I cannot find any civicrm.settings.php file in this version, maybe because the "install" has not been able to take place due to the error I documented above. – EFC Jan 22 at 22:02
  • So you're saying you still get an error on the web page installer screen when you use the "unix(path/to/socket)" format? – Demerit Jan 24 at 0:22
0

Checking out other Stackexchange answers, looks like something along these lines should work

You can set the DSN in the civicrm.settings.php file using this format:

mysqli://user:password@unix(/path/to/socket)/databasename

Use the actual word "unix" in the string to indicate sockets.

For Reference this is the previous answer

| improve this answer | |
  • I've seen a reference to a civicrm.settings.php file but see no such thing in my WordPress installation. Does that file only appear after CiviCRM has been "installed"? – EFC Jan 22 at 22:01
  • Have you tried /wp-content/upload/civicrm/civicrm.settings.php – Parvez Saleh Jan 22 at 22:45
  • Parvez, I have the uploads/civicrm directory, but nothing is in that directory. I think this is because CiviCRM has never installed itself properly, due to the error I describe in my question. – EFC Jan 23 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.