0

Wordpress 5.3.2 CiviCRM 5.21.0

I've recently upgraded to CiviCRM 5.21.0 successfully and everything was working fine.

Whilst tidying up the site, I inadvertently and stupidly changed the CiviCRM Resource URL to the site URL (not the full path) instead of [civicrm.root]/ I now cannot get into CiviCRM admin through Wordpress admin so am unable to change the resource URL back to how it was.

Does anyone know a way of resettting things through FTP or phpMyAdmin please?

The settings in civicrm-settings.php seem OK. I've tried reinstalling CiviCRM but still cannot get into Admin.

Many thanks.

3

The easiest way would probably be to override this value in civicrm.settings.php. There should be a commented out line something like:

// $civicrm_setting['URL Preferences']['userFrameworkResourceURL'] = '....';

You can uncomment this line by removing the leading '//' and edit the url. Make a backup of civicrm.settings.php first.

If you wanted to make a change in the database you can do this by editing the value of civicrm_setting for the row with name "userFrameworkResourceURL".

I'd recommend backing up the database or at least that table first.

If you have logging enabled via (Admin -> System Settings -> Misc (Undelete, PDFs, Limits, Logging, Captcha, etc.) )

You could find the previous value for this in the log_civicrm_setting table.

2
  • Luke - Thank you for your very prompt reply and for the advice. I'll give changing the database setting a try.
    – peterb
    Jan 25 '20 at 0:02
  • Luke - I managed to change the database setting but it didn't immediately solve my problem. However, I did eventually get into CiviCRM admin where the Resource URL was showing as blank. I changed it to [civicrm.root]/ and now things seem to be fine. Thanks again for your help.
    – peterb
    Jan 25 '20 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.