Not sure where I went wrong.

I recently installed the CiviCRM WordPress plugin.

I also installed a number of other plugins, but one of them that was installed after Civi was an SSO one.

I wouldn't think this would negatively affect anything, especially Civi, but apparently it did!

I've tried deactivating the SSO plugin, and seeing if Civi would work, and to no avail.

I even tried deactivating, deleting, and re-installing the Civi plugin 3 times. Still nothing.

enter image description here

As shown in the image, I get the following bit of text on the screen when I go to the CiviCRM tab in my dashboard:

Configure Your Dashboard Refresh Dashboard Data Welcome to your Home Dashboard Your dashboard provides a one-screen view of the data that's most important to you. Graphical or tabular data is pulled from the reports you select, and is displayed in 'dashlets' (sections of the dashboard).

Have absolutely no idea what I'm doing wrong. I really would rather not do a fresh install of WordPress... I already have quite a bit of other things set up, custom styling on my front end, etc.

  • 1
    any javascript errors in the console? maybe directory or url settings are wrong? if you go to /wp-admin/admin.php?page=CiviCRM&q=civicrm%2Fadmin&reset=1 do you see anything?
    – ericG
    Jan 28, 2020 at 23:55
  • No, nothing comes up for that my guy. Jan 29, 2020 at 0:15
  • well, then it's not just a javascript/path issue, sorry
    – ericG
    Jan 29, 2020 at 0:38
  • Great that the CiviCRM community was able to help you out! Don't forget to mark the answer that resolved it with the big tick button on the left. Jan 29, 2020 at 8:55

2 Answers 2



My issue was with the resource URL.

Update the following file: example.org/wp-content/uploads/civicrm/civicrm.settings.php

Approx. line 82: $civicrm_setting['URL Preferences']['userFrameworkResourceURL'] = 'https://example.org/wp-content/plugins/civicrm/civicrm';

I had put an SSL certificate on via my host (SiteGround), just before this issue started happening, which was messing it up.

All the paths need to have https: in them.

Shoutout to Jon G for his help and patience!


Almost every time I've seen CiviCRM fail to load a portion of the screen, it's been a permission issue on the templates_c folder.

I can give the standard fix if you have command line access: Navigate into the templates_c folder and run chown -R <name of web user> . However, every control panel has a different way of handling this - and if the permissions got screwed up, then there's probably a deeper underlying issue (e.g. cron is running as the wrong user).

If you're not sure how to change the owner of templates_c, simply delete it - next time you reload the CiviCRM page, it will be regenerated (correctly). You'll still want to check for a bad cron setup, but it's a good way to quickly see if the issue is indeed a cached template issue.

  • Hey, I tried deleting the templates_c folder like you mentioned. Reloaded Civi. Nothing changed. I haven'te even touched CRON settings yet, so I'm not sure how I could go wrong with something I've never even set up? Jan 29, 2020 at 0:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.