0

Running Joomla 3.9.15, CiviCRM 5.21.2

Was just notified that our initial Membership/Contribution Page was not working properly. After the user enters their data, then get the confirmation page, it should then head to PayPal, but install returns to the main page of the site.

From what I can tell, our renewal page is working fine, as I've gotten a few renewal payments in since I started looking at this, so I don't believe its a PayPal issue.

In addition, it appears that the "Pay Later" option is no longer appearing on the page as one of the payment options. Again, this was working the last time I had to do anything with the page about a year or so ago. I remember it was a fairly active issue on Jira, but was fixed.

One other thing, I created a new page WITHOUT having the automatic renewals option turned on, yet the page still shows this option.

I cleared all the system caches, and the CiviCRM templates_c directory. Any advice would be greatly appreciated.

  • try after resaving the contribution page setting again specially amounts and membership tab – Pradeep Nayak Jan 30 at 15:04
  • Verified that I'm not asking for automatic renewals, and the pay later box is checked and displaying the 'pay later' text on the page settings. Still displays the 'automatic renewal' checkbox on the contribution page, and no 'pay later'. – Neil Z Jan 31 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.