0

I noticed a post in 2018 about my same issue. I am using siteground with "Localdir" (the other posting used SMTP) because our email blasts are small volumes. The emails go out ok, but the civicrm email reports can't find bounces, and clickthroughs ? A siteground support person spent 2 hours "chatting" online trying to help me, but no success. Siteground uses "dovecot" email and all civicrm emails create folder-level addresses like ".bounces.ignored" and "bounces.processed" with three folders under each - "cur, new, tmp". Not sure how to fix/patch this to work ? I am using drupal 7.69 with civicrm 5.22.

  • I'm not sure what you mean by "Localdir". Do you mean mail()? And would be good to link to the related posts (was it one of mine?). I have things working with Siteground now, but need to know more context to respond. – Mick Kahn Feb 10 at 16:35
  • The LocalDir is a protocol on the edit mail account screen (civicrm/admin/mailSettings?reset=1). And I found a post from Anna Sidwell May 31 '18 at 15:45. – barbaraec Feb 10 at 19:02
  • Does siteground not let you access dovecot through IMAP? I mean on your inbound mail account screen for bounce processing, choose imap as the protocol and enter the settings for the dovecot mail server? Using localdir in production is unusual - I usually only use it for testing the email processor. – Demerit Feb 10 at 19:03
  • Where would I set that up? You are indicating to use IMAP instead of Localdir? – barbaraec Feb 10 at 19:15
  • The same place where you set it to localdir. In the inbound mail account screen for bounce processing. Administer - CiviMail - Mail Accounts. – Demerit Feb 10 at 19:28
1

I presume that you are talking about bulk mailings. I have got this working for small volumes hosted on Siteground. I had a lot of problems originally with subfolders though can't remember the details. My solution was as follows.

Outbound use mail() and in Administer>>CiviMail>>Mail Setting, set Mailer Batch Limit to 100 and Mailer Cron Job Limit to 1. With the Send Scheduled Mailings cron job running every half hour this throttles the outbound mail within SiteGround's limits.

Inbound i set up an account on GMail to handle the bounces so bounce processing account (Adminster>>CiviMail>>Mail Accounts) was set up using IMAP to GMail and address examplereturn@gmail.com and localpart return+ and email domain of return.example.org. I then forwarded @return.example.org to examplereturn@gmail.com. The GMail account needs some special settings as described in https://docs.civicrm.org/sysadmin/en/latest/setup/civimail/inbound/#return-channel-google-apps. All rather complicated but nothing else I tried worked.

Hope that helps.

| improve this answer | |
  • Thank you Mick - I will try what you've described today. Very creative and I hope I get it all working ok :-) – barbaraec Feb 11 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.