1

Im getting this error when attempting to add tags to a case.

If I create a case and add tags at the same time, they get added.

If I subsequestly try to remove a tag, no problem.

If I subsequently try to add a tag, I get this error

Something wrong with getting info for tag: Expected one Tag but found 25

Also a huge array in the backtrace but the relevant bit I think is

Something wrong with getting info for tag: Expected one Tag but found 25" } ["message":protected]=> string(72) "Something wrong with getting info for tag: Expected one Tag but found 25" ["string":"Exception":private]=> string(0) "" ["code":protected]=> int(0) ["file":protected]=> string(64) 

If I then try to view the case again, it's unviewable and has to be deleted.

Drupal up-to-date using 5.21.0

backtrace

CiviCRM_API3_Exception: "Something wrong with getting info for tag: Expected one Tag but found 25"

#0 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Case/Form/CaseView.php(359): civicrm_api3("entityTag", "get", (Array:6))
#1 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Core/Form.php(595): CRM_Case_Form_CaseView->buildQuickForm()
#2 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Display.php(76): CRM_Core_Form->buildForm()
#3 /home/vwdnetor/public_html/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Case_Form_CaseView), "display")
#4 /home/vwdnetor/public_html/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Case_Form_CaseView), "display")
#5 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Core/Controller.php(335): HTML_QuickForm_Page->handle("display")
#6 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Case/Page/Tab.php(93): CRM_Core_Controller->run()
#7 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Case/Page/Tab.php(180): CRM_Case_Page_Tab->view()
#8 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(268): CRM_Case_Page_Tab->run((Array:4), NULL)
#9 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(68): CRM_Core_Invoke::runItem((Array:13))
#10 /home/vwdnetor/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(36): CRM_Core_Invoke::_invoke((Array:4))
#11 /home/vwdnetor/public_html/sites/all/modules/civicrm/drupal/civicrm.module(456): CRM_Core_Invoke::invoke((Array:4))
#12 /home/vwdnetor/public_html/includes/menu.inc(527): civicrm_invoke("contact", "view", "case")
#13 /home/vwdnetor/public_html/index.php(21): menu_execute_active_handler()
#14 {main}

Also I'm getting console error 500 on

/civicrm/contact/view/case?reset=1&id=859&cid=1777&action=view&context=case&selectedChild=case&key=d880725325c5ab758814d913d9a0790e_7084
  • I'm not able to reproduce this with the latest master code with either tag sets or bare tags. Are you able to reproduce on dmaster.demo.civicrm.org? You can still post the huge backtrace - it would be helpful to see it. Also do you have any relevant extensions installed? – Demerit Feb 13 at 13:58
  • @demerit apols did not make it clear - don't think it's a general bug. Original question updated with backtrace and console error. Also the error log is huge rather than the backtrace – Tony Horrocks Feb 13 at 20:23
  • Ok thanks. Do you have any customizations? I'm not sure where the phrase "Something wrong with getting info for" is coming from. Also does your line 359 in CRM/Case/Form/CaseView.php match exactly up to this line or is it off by one line? github.com/civicrm/civicrm-core/blob/5.21.0/CRM/Case/Form/… – Demerit Feb 13 at 20:41
  • @Demerit there are extensions but all mainstream. I disabled all to check but same error. Lines up OK on 359. I'm not seeing that string anywhere either. – Tony Horrocks Feb 13 at 21:04
  • Hmm. Ok how about if you do grep -r "Something wrong with getting" * from within the civicrm folder - does it show any output? – Demerit Feb 13 at 21:07
1

I'm going to bet this is something to do with the civimobile api extension, even though you mentioned you tried disabling. That's the only place I can see the phrase "Something wrong with getting"

https://lab.civicrm.org/extensions/civimobileapi/blob/4.2.1/CRM/CiviMobileAPI/ApiWrapper/EntityTag/Get.php

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.