1

As per title, after a user registers for an event and goes through the confirmation screen, they are treated to the following error:

GDPR CiviEvent Error

Notice: Undefined index: comm_pref_in_thankyou in /opt/bitnami/apps/wordpress/htdocs/wp-content/uploads/civicrm/ext/uk.co.vedaconsulting.gdpr/CRM/Gdpr/CommunicationsPreferences/Utils.php on line 507

Notice: Undefined index: comm_pref_in_thankyou in /opt/bitnami/apps/wordpress/htdocs/wp-content/uploads/civicrm/ext/uk.co.vedaconsulting.gdpr/CRM/Gdpr/CommunicationsPreferences/Utils.php on line 508

As you can see in the screenshot, their details are registered and it goes through fine in Civi's backend, we are just getting this error as well which is seemingly linked to the GDPR extension.

Due to running a hosted system, I am unable to check the PHP file but I am speaking to our host regarding this as well. I am asking here in the hopes someone has seen this before and knows what the error is expecting.

Running on Wordpress 5.3.2 with CiviCRM 5.21.1 The GDPR extension is version 2.8

2

Its just the warning (Notice), either you can turn off php warnings for wordpress or update the GDPR Communications Preferences settings(http://domain.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/gdpr/comms-prefs/settings&reset=1) and choose something (eg Do Nothing) for 'Add to Event and Contribution Thank-you pages' option under 'Event & Contribution thank you page' section.

HTH

Pradeep

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.