2

I have a set of custom relationships I need to import against, but the import mapping dropdowns are only showing the three default relationships:

Employee of.. Family member is.. Household member is..

Any ideas? I cannot see any options on the custom relationship settings i need to change. We are using CiviCRM 4.6.2 (recently upgraded)

  • What shows up in the drop down is determined a bit by rather or not you importing households, individuals or organizations and what the custom relationship apply to, e.g. individuals. If you aren't already, you might import the contact and then do a second pass for the relationship and do update. Also, try reversing what your adding the relationship to. For example, if you're trying to import an individual as part of household, try importing update the hh and add the ind as a hh member – Paul-Tahoe Jun 23 '15 at 16:20
  • Thanks Paul - it turned out that relationships needed to be set up at contact type level, not as a contact sub type in order for the relationships options to be displayed in the import screens – Catherine Jul 15 '15 at 16:29
  • Catherine if you want you can put what you wrote as an answer. That way other people who trip across the same thing will have an answer. You might elaborate on exactly how you were trying to import and what you did to fix it. – Paul-Tahoe Jul 15 '15 at 17:34
3

Thanks Paul - it turned out that relationships needed to be set up at contact type level, not as a contact sub type in order for the relationships options to be displayed in the import screens.

So where contact sub types had been set up on earlier versions of civi, the relationship had to be changed to conctact type leve i.e

individual to individual not Individual (parent) to Indiviudal (child)

The relationship names can stay the same just not the level.

  • 1
    IMO that is a bug and you should consider reporting. – Sonicthoughts Jul 24 '15 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.