1

Whenever I try to install/uninstall CiviCRM extensions or run Cleanup Cache, I consistently receive this error:

Warning: require(/home/xxxxxxxx/public_html/wp-content/uploads/civicrm/templates_c/CachedExtLoader.8fc40bba39c0b8bd10ea54175cf9a6b3.php): failed to open stream: No such file or directory in /home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/CRM/Extension/ClassLoader.php on line 70

Fatal error: require(): Failed opening required '/home/xxxxxxxx/public_html/wp-content/uploads/civicrm/templates_c/CachedExtLoader.8fc40bba39c0b8bd10ea54175cf9a6b3.php' (include_path='/home/xxxxxxxx/public_html/wp-content/uploads/civicrm/ext/org.civicoop.pdfapi/:/home/xxxxxxxx/public_html/wp-content/uploads/civicrm/ext/org.civicoop.civirules/:/home/xxxxxxxx/public_html/wp-content/uploads/civicrm/ext/org.civicrm.volunteer/:/home/xxxxxxxx/public_html/wp-content/uploads/civicrm/ext/org.civicrm.angularprofiles/:.:/home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm:/home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/packages:/home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/vendor/tecnickcom:/home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/vendor/phpseclib/phpseclib/phpseclib:/home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/vendor/pear/pear_exception:/home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/vendor/pear/auth_sasl:/home/xxxxxxxx/public_html/wp-content in /home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/CRM/Extension/ClassLoader.php on line 70

There has been a critical error on your website. Please check your site admin email inbox for instructions.

civicrm.settings.php seems fine:

global $civicrm_root;

$civicrm_root = '/home/xxxxxxxx/public_html/wp-content/plugins/civicrm/civicrm/'; if (!defined('CIVICRM_TEMPLATE_COMPILEDIR')) { define( 'CIVICRM_TEMPLATE_COMPILEDIR', '/home/xxxxxxxx/public_html/wp-content/uploads/civicrm/templates_c/');

Wordpress 5.3.2 CiviCRM 5.22.0 PHP 7.3

The email sent by the system had almost the same message:

Error Details ============= An error of type E_COMPILE_ERROR was caused in line 70 of the file /home/nkxwvwvr/public_html/staging02/wp-content/plugins/civicrm/civicrm/CRM/Extension/ClassLoader.php. Error message: require(): Failed opening required '/home/xxxxxxxx/public_html/staging02/wp-content/uploads/civicrm/templates_c/CachedExtLoader.697f143a9f2872e12a14e35583756c82.php' (include_path='.:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/packages:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/vendor/tecnickcom:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/vendor/phpseclib/phpseclib/phpseclib:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/vendor/pear/pear_exception:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/vendor/pear/auth_sasl:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/vendor/pear/log:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/vendor/pear/console_getopt:/home/xxxxxxxx/public_html/staging02/wp-content/plugins/civicrm/civicrm/vendor/pear/pear-core-minimal/src:/ho

5
  • try reloading your php-fpm or ngnix or apache Feb 21 '20 at 23:19
  • The host restarted them. No difference. They say, "If the issue is still there, i would recommend having a developer look into this, as this appears to be PHP error." I even lowered PHP from 7.3 to 7.2. No difference.
    – Día
    Feb 22 '20 at 16:14
  • "There has been a critical error on your website. Please check your site admin email inbox for instructions." What does the mail say? You could try manually removing /home/xxxxxxxx/public_html/wp-content/uploads/civicrm/templates_c
    – Aidan
    Feb 22 '20 at 20:22
  • The email contained pretty much the same error as I see on the screen. I just placed the error in the original post. Also, deleting templates_c doesn't help.
    – Día
    Feb 23 '20 at 19:58
  • It's happening at one webhost and not another. The only difference in setup is that the failing webhost is using EasyApache.
    – Día
    Feb 26 '20 at 23:17
1

The hosting company sent me this instruction. It worked, and I'm back in business!

"You need to add this in your .htaccess file to avoid problem, it is caching related:"
php_flag opcache.enable Off

0

I've been tearing my hair out on this one, attempting a clean CiviCRM install

Same error as above, during install. Clearly something to do with the database, as the install ran for a minute, and produced the error, but no tables were ever written to the database.

I know all requirements are met, as we already have two other running copies of CiviCRM on the same server.

My fix, for what it's worth, was to locate a copy of CiviCrm 5.28 (yeah, I had a very old backup lying around), install that, and then upgrade! Still have no idea what the cause was, but at least now I have a clean install of Civi running.

Ubuntu Server 18.04 MYSQL 5.7.35 PHP 7.4 Attempted install - CiviCRM 5.41.2 on Wordpress 5.8.1

Might help someone (might not)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.