1

When I try to continue editing a CiviMail email we get the following error after upgrading to 4.6.4 from 4.5.5.

CiviCRM_API3_Exception: "DB Error: no such field"
#0 /home/sitename/public_html/sites/all/modules/civicrm/CRM/Mailing/Info.php(111): civicrm_api3("Mailing", "get", (Array:5))
#1 /home/sitename/public_html/sites/all/modules/civicrm/Civi/Angular/Manager.php(130): CRM_Mailing_Info->getAngularModules()
#2 /home/sitename/public_html/sites/all/modules/civicrm/Civi/Angular/Page/Main.php(66): Civi\Angular\Manager->getModules()
#3 /home/sitename/public_html/sites/all/modules/civicrm/Civi/Angular/Page/Main.php(58): Civi\Angular\Page\Main->registerResources()
#4 /home/ccsdfoundation/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(312): Civi\Angular\Page\Main->run((Array:2), NULL)
#5 /home/sitename/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:12))
#6 /home/sitename/public_html/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:2))
#7 /home/sitename/public_html/sites/all/modules/civicrm/drupal/civicrm.module(489): CRM_Core_Invoke::invoke((Array:2))
#8 [internal function](): civicrm_invoke("a")
#9 /home/sitename/public_html/includes/menu.inc(519): call_user_func_array("civicrm_invoke", (Array:1))
#10 /home/sitename/public_html/index.php(21): menu_execute_active_handler()
#11 {main}

2 Answers 2

1

No such field errors after an upgrade are most commonly caused by not having run the DB upgrader.

  • For Drupal, visit ?q=civicrm/upgrade&reset=1 or civicrm/upgrade?reset=1
  • For WordPress, visit wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1
  • For Joomla, visit /administrator/index.php?option=com_civicrm&task=civicrm/upgrade&reset=1

For full upgrade advice and various troubleshooting tips, refer to the upgrade documentation page for your CMS.

5
  • I ran the upgrade and it completed without errors.
    – Steve
    Commented Jun 23, 2015 at 22:23
  • 1
    There's also a document on ensuring schema integrity on upgrades? The first step I'd take would be to compare the DB result of SELECT version FROM civicrm_domain against the version of the codebase you think is installed. If they don't match, you might have an incompletely upgraded codebase. Commented Jun 24, 2015 at 4:09
  • The version is 4.6.4 .
    – Steve
    Commented Jun 24, 2015 at 22:13
  • The databases match and I am not sure what I am doing with comparing the schema. I found this on GitHub but it is not setup for 4.6.4 github.com/progressivetech/civi-schema-harmonizer
    – Steve
    Commented Jun 26, 2015 at 20:49
  • I was able to get the schema harmonizer to work with some tinkering and the site is running well now.
    – Steve
    Commented Jun 28, 2015 at 19:42
1

I was able to use the GitHub project at github.com/progressivetech/civi-schema-harmonizer with some tinkering to make it work. I documented my tinkering in the issues for the git project.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.