I'm using Wordpress 5.3.2 multisite and CiviCRM 5.22.1. Installing CiviCRM in a subdomain, and can't get the CiviCRM installer to work. I created a new mySQL database. Ran the first stage of the installer that gave two warnings (a) is the utf8mb4 character set supported? (I selected utf8mb4-general as it didn't have utf8mb4 alone) (b) PHP7 installed (I'm running with PHP 7.0.33 as later versions break my Wordpress installation)

I'm also using the UK language. The CiviCRM Database settings are localhost, the username and password, and the database called thinkne2_ctga as it happens.

The Database version and connection settings have been verified and are correct green banner shows.

So I then click on the 'Check Requirements and install CiviCRM' button - which starts the installation process which leads to a large screen showing what looks like SQL errors which starts:

DB_Error Object ( [error_message_prefix] => [mode] => 1 [level] => 1024 [code] => -18 [message] => DB Error: no such table [userinfo] => /******************************************************* * * civicrm_county * *******************************************************/ INSERT INTO civicrm_worldregion (id, name) VALUES("1", "Europe and Central Asia") [nativecode=1146 ** Table 'thinkne2_ctga.civicrm_worldregion' doesn't exist] [backtrace] => Array ( [0] => Array ( [file] => /home/thinkne2/public_html/wp-content/plugins/civicrm/civicrm/packages/DB.php [line] => 998 [function] =

Clearly I'm doing something stupid. Any ideas on how I should work out what is going wrong?

** UPDATE **

I only deleted the CiviCRM installation in the subdomain and reinstalled it. The installation process then failed as above.

I've now deleted the application in wp-content/plugins as well, and then reinstalled everything. Now appears to be working. So my advice to anyone with the same problem is start from scratch.


David Brown

  • 1
    I'd look at why PHP 7.1+ breaks your WordPress install first. CiviCRM definitely runs best with a more recent version of PHP. IIRC, it's going to require PHP 7.1 shortly. – Christian Wach Mar 4 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.