13

On the CiviCRM download page there is an LTS version underneath the current one. What's the difference, and which should I use?

13

LTS stands for Long Term Stable version. It is intended for use on more conservative sites that are more concerned with having a stable CiviCRM environment than with having access to the latest features in CiviCRM. You should decide which type of site yours is.

The LTS version contains all fixes for security vulnerabilities that affect the software, and many but not all of the bug fixes that are available in the stable version. As mentioned, it does not contain the new features made available in more recent versions.

The LTS version tends to be one or two minor versions behind the latest stable version. So a little while after 4.5 was released as the latest stable version, the LTS version switched from 4.2 to 4.4, skipping 4.3. Similarly, in late 2015 likely after 4.7 came out, 4.6 became the LTS version, skipping 4.5. Now that it is April 2016, the expectation is that 4.7 could become the next Long Term Stable release after 4.6, in anticipation of significant changes in 5.0. But the final decision on this won't likely be made until late 2016 / early 2017.

The benefits of using the LTS (long term stable) release are:

  • There are fewer unknown bugs in the software since it has been used extensively for a long time.
  • Upgrading within one release branch like 4.2 or 4.4 is less likely to require extra effort or cause problems than upgrades from 4.2 to 4.3, or 4.4 to 4.5.

Downsides to using LTS include:

  • Not having access to the features available in more recent versions of CiviCRM.
  • Not having access to extensions or releases of extensions that are only available for more recent versions of CiviCRM.
  • Not having access to some bug fixes that are included in more recent versions of CiviCRM (usually ones that are not important or that require a lot of work to backport).
7

We advise our customers to stay on the LTS versions of CiviCRM unless they have a functional need for the latest and greatest. This is in line with the detailed explanation that Joe Murray entered (thanks Joe).

5

The current trend (although this may change in the future) is for even-numbered versions to get long term support (LTS) while odd numbered versions don't.

If you are installing CiviCRM for the first time, I recommend always going with the latest version and not LTS. This is because there is a cost to upgrading, and starting off on a higher version # means fewer upgrades are in your immediate future.

Once you have been running CiviCRM for a while and newer versions are released, you'll need to decide when to upgrade. There are at least 3 approaches:

  1. Cutting Edge: always upgrade to the latest release to gain the benefits of new features (and possibly face new bugs).
  2. Conservative: always stay on the LTS version, upgrading only when a new LTS is announced and the current one is retired.
  3. Middle-of-the-road: when a new .0 version is announced (e.g. 4.6.0) sit back and wait a few weeks until the majority of bugs are found and fixed, then upgrade when it is at .3 or .4.
  • It's worth noting that it's difficult to guess which minor version will become the LTS. So, for instance right now, LTS is 4.4 while latest is 4.6.7. So we might expect 4.6.? to become LTS when 4.7 released (scheduled Oct 2015). So it's tempting (if you need features not in LTS) to use latest and hope to hop over to new LTS, but last time I tried this I got ahead of the LTS 4.4 release; i.e. I got stuck on latest. – artfulrobot Aug 21 '15 at 13:14
  • I've been thinking about that too. It would be nice if we gave advanced notice (I think it's buried in a blog somewhere, but more prominently) of our intentions. In this case yes, 4.6 will be the next LTS. – Coleman Aug 21 '15 at 18:30
1

At Cividesk we recommend going with the LTS. That may be because we help maintain the LTS ;). All security fixes are backported to the LTS and it tends to be more stable than the newest release. As @Coleman points out the newest release does get more stable over time so this is something to consider as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.