When i try to update my Joomla version (Windows) to 5.23.0 I get the screen to run the database upgrade utility after the question are you ready to upgrade (Yes) I get the screen with the progress-bar left at the screen but it does nothing. When I look at the console of the screen I see warnings as: Laden voor het met bron ‘http://localhost/Joomla/Joomla/administrator/components/com_civicrm/civicrm/bower_components/jquery/dist/jquery.min.js’ is mislukt. (and 14 others). The URL must be with only once "/Joomla". I didn't change or save the civicrm.settings.php. But there is no double /Joomla. What is the reason that the URL is wrong? I have tried version 5.23.1 with the same result.

  • can you check civicrm.settings.php if $civicrm_root is set properly? Commented Mar 11, 2020 at 20:20
  • $civicrm_root = 'C:\wamp\www\Joomla\administrator\components\com_civicrm\civicrm';
    – HanV
    Commented Mar 12, 2020 at 15:07
  • That is the same value as in an version 512 civicrm_settings.php. Without a backslash at the end (in the example above it is with a backslash, but i do not think it must be with a backslash, it works the same. I think the statements are generated in CRM/CORE/Resources.php but in line 824 bower_components en 825 packages there is something done with slash and not with the backslash, that are the statements where i get the double Joomla part. Maybe it has something to do with an update in 5.23.0 to allow a path to be relative releas-notes/5.23.1.md.
    – HanV
    Commented Mar 12, 2020 at 15:23

1 Answer 1


I have updated the lines 824 en 825 in CRM/CORE/Resources.php with a dirty solution:

$map = ['bower_components' => str_replace('Joomla/Joomla','Joomla',rtrim(Civi::paths()->getUrl('[civicrm.bower]/.', 'absolute'), '/')), 'packages' => str_replace('Joomla/Joomla','Joomla',rtrim(Civi::paths()->getUrl('[civicrm.packages]/.', 'absolute'), '/')), ];

It can not be the real solution but the site is now working and i have just completed succesful the database-upgrade. Maybe only a problem with sites on Windows.

  • The problem is solved in version 5.23.4
    – HanV
    Commented Mar 28, 2020 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.