2

I'm using Stripe Payment Processor 6.3.2, MJWShared 0.6 on Civicrm 5.23.2 with Wordpress Multisite.

I've used the Wizard to instal webhooks in Stripe.

I'm now getting a warning in CiviCRM System Status "Webhook API version is set to 2020-03-02 but CiviCRM requires 2019-12-03. To correct this please delete the webhook at Stripe and then revisit this page which will recreate it correctly. Webhook path is: https://xxx.xxxx,com/?page=CiviCRM&q=civicrm/payment/ipn/2."

If I delete the webhooks on the Stripe Dashboard, the Wizard can again be used to instal webhooks, but the same warning message comes up.

Any ideas on how I proceed? Or indeed where this process is documented?

David Brown

2

If the Stripe webhook wizard is creating webhooks with the wrong API version, that's a bug, and should be reported on https://lab.civicrm.org/extensions/stripe/issues.

To allay your concerns - it's very unlikely that you're going to experience any ill effects from this. The check in question is mostly concerned with folks running older versions of the Stripe API, and the API doesn't change that drastically from version to version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.