1

Yesterday I prepared a Mosaico mailing for approval. Today I was going to send it. But when I go to the mailing page, I get this error: "Mosaico cannot be displayed because this system does not meet all requirements. For details, check the System Status."

System Status has this warning: "Graphics driver not available Mosaico requires a graphics driver such as PHP-ImageMagick or PHP-GD. For more information, see Mosaico Settings. Error: Failed to locate Mosaico graphics driver. Either "mosaico_graphics" is invalid or the autodetection failed."

Mosaico Settings gives me no options or useful information, which is weird:

I'm running on PHP 7.2, and my host's PHP extensions include ImageMagick for 7.2.

I have made no changes or updates to Civi or the host in the past 24 hours, so I am baffled as to what has broken Mosaico, but I need to get this mailing out ASAP!

Any advice out there?

5
  • 2
    I went into the db and manually created a Mailing Job to get it sent (the message didn't require editing), so my urgency is relieved. But I'm still going to want to use Mosaico at some point! Mar 27 '20 at 19:26
  • 1
    Do you have full control over your server, or does a host do software updates on the server? While you may not have made changes, the host may have. I've had issues where they upgraded something on the server that I was using and now it was an unsupported version, was now in a new location, etc. Mar 30 '20 at 9:15
  • 1
    This might help: civicrm.stackexchange.com/questions/30856/…
    – Aidan
    Mar 30 '20 at 10:16
  • OMG, @Aidan, I even commented on that thread! smh. My issue then was after an update, and Cleaning Up the caches worked for me. Trying to do that today, and I discovered that the problem is solved BEFORE I cleaned up the caches. So, my guess is it was either 1) it was a server host issue (as per @jenni-simonis) or 2) the caches were cleaned up automatically when expired. Mar 30 '20 at 14:34
  • ... well I wasn't going to mention that you commented on that post :-) Good to hear it's working now.
    – Aidan
    Apr 1 '20 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.