I am running on CiviCRM 5.21.1, and have just upgraded CiviRules from 2.11 to 2.13.

I have several Rules which test for the Type of a Contact by using e.g. "Field Value Comparison Contact.contact_type=Individual"

After the upgrade this rule does not fire, and the Condition appears on the Rules Management screen as "Field Value Comparison Contact.contact_type=". If I try to recreate the condition I get the same result, and I can see no other way of making this test.

I will have to stay on CiviRules 2.11 until this is fixed.


  • Is this just an example or is this actually the condition your are using? If so, have you tried the "Contact (Sub)Type" condition? Does that have the same problem? Mar 30, 2020 at 17:54

2 Answers 2


Try after applying patch from here on latest version of rules.


I also raised this as a formal Issue and got the response here https://lab.civicrm.org/extensions/civirules/-/issues/70. There is a fix, and the issue is now closed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.