3

I tried upgrading to 5.24 and it hung half way through the upgrade - while upgrading to 5.24alpha1. Here's all that was in the log - it then died. I've gone back to 5.23.4 (Drupal). Ideas?

Apr 02 09:21:30 [info] Running task: Cleanup old files
Apr 02 09:21:31 [info] Running task: Checking extensions
Apr 02 09:21:31 [info] Running task: Begin Upgrade to 5.24.alpha1
Apr 02 09:21:32 [info] Running task: Upgrade DB to 5.24.alpha1
Apr 02 09:21:33 [info] Running task: Upgrade DB to 5.24.alpha1: SQL
Apr 02 09:21:34 [info] Running task: Install sequential creditnote extension

  • Did it succeed in installing that extension? Are there any errors in webserver logs, or CMS logs? – Aidan Apr 2 at 9:04
  • I restored the database, which is shared with Drupal, so the only thing I have is the above log. I'll retry the upgrade and look further – Andy Clark Apr 2 at 9:11
  • I ran the upgrade again, nothing in civicrm_log or Drupal's log, nothing more in ConfigAndLog, and no extension installed. I can try again with some diagnostics. Also I do have a lot of extensions, I could do some gradual disabling. This is a test system, by the way! – Andy Clark Apr 2 at 13:07
  • Ok, since it's a test system would be interesting to try installing that extension manually after the upgrade has failed and see if you get more error messages that way. – Aidan Apr 2 at 15:18
  • (a) +1 for disabling some other ext's as debug tactic. (b) You might get better debug info with one of these patches: gist.github.com/totten/96aa7172faced3fde2225e145307f3b9 (c) You might also get more debug info with a CLI runner (eg cv upgrade:db -vvv). – Tim Otten Apr 2 at 23:26
4

I was able to reproduce a similar symptom in a wp-demo configuration. Specifically, the upgrader activates the new, core-internal extension (sequentialcreditnotes), and the activation fired off a general system-flush, and the general system-flush raised an error while handling some data from another extension (civivolunteer). The problem only occurred with the web-based upgrade UI (and not with the CLI-based upgrader).

CiviCRM 5.24.1 has a fix for that case.

| improve this answer | |
0

On WordPress version, tried to upgrade from 5.21.2 to 5.24.0 twice and had the same issue. Freezes on: Executed: Upgrade DB to 5.24.alpha1: SQL Had to restore previous day's back up to bring database back. No error messages, just the freezing.

| improve this answer | |
  • I was able to reproduce this problem. The following fixed it for me: github.com/civicrm/civicrm-core/pull/16971 – Tim Otten Apr 3 at 22:33
  • I saw the same under Joomla. My test Joomla instance ran to completion, but the CiviCRM menu disappeared! – Stephen Palmstrom Apr 4 at 14:39
  • Glad you found a fix, Tim and thanks for letting us know . I'm surprised this didn't occur in testing as it was such a solid error. – Andy Clark Apr 4 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.