1

I've just a done a clean install by the book of CiviCRM 5.24 on Drupal 7. The installation went smoothly. Now I'm seeing an alert about the Resource URL being incorrect (it isn't). I seem to recall that this was an issue a year or so ago. Is this a regression that has crept in to the latest version, or am I doing something wrong? I have other D7/Civi installs on the same server, all with earlier versions of CiviCRM, and none of them are exhibiting this behaviour.

  • 1
    Are you using a self-signed ssl certificate? – Demerit Apr 4 at 17:04
  • LetsEncrypt certificate – Graham Apr 5 at 8:42
  • 1
    Ok then here's a couple things to try: 1. Can the server itself look up the domain name, e.g. using command line nslookup or dig? 2. Put some debugging just after line 867 in CRM/Utils/Check/Component/Env.php to verify what url it's trying to fetch, e.g. add CRM_Core_Error::debug_log_message($arrowUrl); and then look in ConfigAndLog. – Demerit Apr 5 at 15:20
  • 1
    Looks like there might be an issue with the DNS servers that my server is using by default to look up the domain. It appears that my domain's records have not propagated to these servers, although I can reach the domain from elsewhere. Talking to my hosting provider... – Graham Apr 5 at 17:28
1

The Resource URL lookup uses the PHP setting curl.cainfo to look up a certificate file, e.g. CACert.pem to validate the server certificate. I found the problem went away when I added the server certificate to that file.

See Installing drupal 8 using civicrm-setup leads to "incorrect resource url" system status check errors

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.