1

I'm building a membership sign-up form. The membership has a price set, and I'm using this guide from Tadpole which looks to be pretty close to my situation.

What I've found through extensive testing and several attempts to rebuild the form in case I've missed something, is that although I have three line items in my price set (one offers a range of pricing options based on user-selected preferences, and the other two are simple optional add-ons) and all three are included in my order processor, when I run test transactions I only ever get the first two recorded both in the Stripe transaction and in the contribution record.

I've tried various options including re-ordering the line items, but nothing seems to make any difference.

Noting that the current version of the cf-Stripe processor from Caldera didn't work at all, cos it uses Stripe checkout rather than the on-page JS approach, I downgraded to version 1.4.7 on the advice of Kevin Cristiano. That got the contribution to record, but I remain stuck with only being able to handle two line items.

I'm wondering whether this might also be down to version-specific requirements with the core Caldera Forms plug-in, given that the most recent release of the cf-civicrm plugin dates back to Nov 2019? Should I be using an older version of the forms plugin? I'm running 1.8.11.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.