3

Since CiviCRM 5.23, one can set a custom L10n/I18n resource directory. Using this feature with Aegir and Drupal 7 profiles, this setting almost works: CiviCRM sites install with selected language, using the Drupal and CiviCRM language files (.po/.mo) located now at profiles/myprofile/translations/.

Missing piece is that the settings.default.json file of CiviCRM l10n settings is not picked up during install, so its settings are neglected. The file is at civicrm/l10n/hu_HU, next to the .po files.

Is it a bug or am I missing something in my Aegir settings?

2

The solution was:

  1. Add a define('CIVICRM_L10N_BASEDIR', '/var/aegir/platforms/YOUR-PATH'); statement to platform.settings.php file of Aegir (see: Altering Aegir's Behaviours), to set an environmental variable for CiviCRM, to locate the exact place of its l10n files. More info on CIVICRM_L10N_BASEDIR here and here.

  2. Correct the line breaks of the example settings.default.json, otherwise it's not being read as JSON file. The address_format and mailing_format should be one line, and \n have to be added when line break is required. See MR.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.