1

Somehow I seem to have deactivated the type of relationship 'Household member' (is a member of what household) through the interface while configuring a fairly new CiviCRM. As a result, I don't seem to be able to associate individuals to households. Nothing has been changed in code, so I must have just clicked on something. On the relationship types page, this relationship (is a member of) is of course still there (it can't be deleted through the interface, afterall), but doesn't allow itself to be actived (though other options like 'child of' or 'spouse of' can be activated and deactivated). I'm the only person who's been configuring the site, so I don't see how it can be a permissions issue (it must be a problem that I created).

Any ideas what I need to do to re-activate this basic relationship type?

Thanks very much!

Steve Baird, Citizen's Action Committee of Verdun

1

Do you have any extensions that might have disabled it? Otherwise I'm not sure how that would happen either but if you want to live on the edge you can use phpmyadmin or equivalent to do:

UPDATE civicrm_relationship_type SET is_active=1 WHERE name_a_b = 'Household Member of';

You can also do it with api explorer (/civicrm/api3) and choose:

Entity: RelationshipType

Action: Create (yes, create - it means update)

Remove the suggested parameters and add a parameter Relationship Type ID = 8. You can confirm the id by hovering over the View link in the Relationship Types listing screen and looking at the url at the bottom of the browser, but it's always 8.

Then add a parameter Relationship type is Active = Yes

Click Execute.

| improve this answer | |
  • I don't think that any extensions have been added lately, though I changed some settings of an extension or two (mostly CiviCase). It's in a shared hosting environment, so admittedly I might just have to contact the host and ask them whether they would be comfortable making a change the one you suggested. – Steve Baird Apr 22 at 19:10
  • 1
    Worked great, thanks! In relation to my comment above, I didn't realise when I first read this answer that I would indeed have access to the api explorer despite being in a shared hosting environment, but I do. So if others have the same problem, I encourage you to try the link mentioned in the answer above. – Steve Baird Apr 29 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.