1

Is there a way to reduce the number of 0 after colon in a simple price field in the backend?

i

For example, this is what I see in Price Fields Window.enter image description here

I read this post and JonG's answer but I'm not working on a simple donation.

I use CiviCRM 5.19.3 on Drupal 7.67 and currency is euro.

Regards,

Guillaume

  • What version of CiviCRM are you using? Can you show a larger screenshot that show which screen you're on? What is your default currency? – Jon G - Megaphone Tech May 1 at 11:55
  • I've edited my post – Guillaume Sorel May 1 at 13:54
  • Is the server on windows? There's still some problems with 0's on windows, including that screen. – Demerit May 1 at 16:59
  • no it's debian or ubuntu one – Guillaume Sorel May 1 at 17:30
2
  1. The backend isn't exposed to the visitor, so you might just not worry about it.

  2. There is a good reason to have currency showing to what might seem an excessive number of places: taxes! For example, a membership price on that screen would be showing the amount exclusive of taxes, and if you lived somewhere that typically shows prices with tax included, then you might want a membership price that makes use of those extra places.

| improve this answer | |
  • thanks Alan, this makes sense. Our customer are mostly not-for-profit organization without tax duty but it could be in some way useful. – Guillaume Sorel May 6 at 9:24
0

Try adding %!.2n in 'Monetary Value Display' under localization settings(administer>> localization >> Languages, Currency, Locations)

| improve this answer | |
  • it didn't bring any changes :-( thanks anyway Pradeep. – Guillaume Sorel May 1 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.